DMA transfer for Hard Disks

  WHogarth 21:40 19 Sep 05
Locked

My PC has two Hard Disks both on the same IDE channel, one as Master being 20GB, and the Slave being 80GB. The Master has all my programs on it but although the Device Manager indicates it can use the DMA transfer mode if availsble, it is using the slower PIO mode. The Slave on the other hand is using the Ultra DMA Mode 5. How can I get my Master HD to use DMA?

  Fruit Bat /\0/\ 22:10 19 Sep 05

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

Alternative Method—Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.

3. Driver is not intended for this platform
If you keep getting the following error message:

There is a problem installing this hardware.

IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

then the way out is to rename C:\WINDOWS\system32\drivers\atapi.sys (or a similar path on your computer) to something like atapi.old.

  WHogarth 23:06 21 Sep 05

Many thanks to Fruit Bat/\0/\ for the two suggestions but no success! In the case of deleting the entries from the Registry I found that after rebooting the entries were back in and the transfer mode on my Master disk was still PIO although it said 'use DMA if available'. The second suggestion puzzled me a bit because it referred to my Secondary IDE Channel - I suppose one can't uninstall the Primary IDE Channel because how would the PC start after rebooting? The Master disk with the problem is a Nikimi NIK-XC204A 20GB unit - I assume it has a DMA facility? Further suggestions very welcome.

  gudgulf 23:21 21 Sep 05

A quick scan on Google suggests the Nikimi drive you have is a SCSI drive....is that correct?

If so then

"SCSI drives

SCSI drives can also use DMA to transfer the data.
However there is no setting in Windows to enable DMA for SCSI drives.
This is because the SCSI hostadapter takes care of this.
So if you have a busmastering SCSI card then DMA is automatically used."

from click here

  WHogarth 12:59 24 Sep 05

Thank you gudgulf for providing a wealth of information with your 'click here' button. My Nikimi drive is on the primary IDE channel -I have checked inside the PC. Your blue button took me to an interesting site then from the Windows XP hdng I went to the MS site which has brought to light a lot! I need to consider the info obtained before I know whether the problem is resolved!! Will be back ASAP.

  WHogarth 12:04 29 Sep 05

I've followed up all the leads suggested by Gudgulf but still no success although have one funny situation - at initiation of start-up when the display shows checking of memory etc. it lists my two Hard Drives and states 'Ultra DMA Mode 5' under each of them!! But later when I enter Device Manager, etc. it says as before for the NIKIMI HD : Transfer Mode - DMA if available, Current Transfer Mode: PIO Mode!!!! I also checked the manufacturers of my Motherboard for an updated BIOS because my BIOS in the standard CMOS Setup Page doesn't lists DMA only PIO. Have downloaded a new BIOS but haven't had courage to try. Should I have a go - any thoughts please?

  Yoda Knight 12:16 29 Sep 05

You sound like you know your way around a pc enough to have a bash at it. Make sure you have read up on how to do it and that you have the correct files. It can be damaging if done incorrectly, but if being afraid to try something never got anyone anywhere - GO FOR IT !

  gudgulf 13:11 29 Sep 05

I,ve been doing a bit more Googling on Nikimi drives.It seems that there is a possibility that the drive you have is a refurbished/rebranded one from another manufacturer.click here

If this is the case it might be that the BIOS and/or windows is not able to correctly identify the DMA mode to apply,in which case it will default to PIO mode to ensure the drive will function.I'm not sure that there will be a solution to this.

The best answer may be to buy a new drive...small capacity ones are very cheap at the moment and transfer everything to the new drive.

  WHogarth 11:25 30 Sep 05

I like gudulf's suggestions of 13.11 on 29/09/05 - the NIKIMI drive was a bit strange from the start because initially it was quoted as just 10 GB! I see in the Feb. issue, page 127, there's a method for copying all my programs, etc. from the NIKIMI to my other HD, but I can't find the quoted file XCOPY32.EXE in my WINDOWS XP system. Please, final advice required?

  Fruit Bat /\0/\ 12:05 30 Sep 05

NIKIMI rebadge Quantum fireball

Quantum now owned by Maxtor try maxblast 4 Maxblast4 click here

if it recognises the drive yu can copy every thing to the new 80G drive then make that master

  Yoda Knight 12:06 30 Sep 05

It may just be callde xcopy.exe, Google will tell you where you can get a copy if u need to...

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…