DMA settings for cdrom

  ashdav 00:43 25 Feb 05
Locked

my cdrom has suddenly stopped reading discs ( CD and data) but strangely will run and boot from my XP disc. I've tried sfc /scannow but found nothing amiss. All drives are enabled,detected and set to auto in BIOS. The only thing that appears to have changed is that under IDE ATA/ATAPI in device manager transfer mode is set to DMA if available but current mode is shown as Multi-word DMA mode2 where it used to be Ultra DMA mode2 (same as CD writer still is). Tried deleting and reinstalling but nothing changes. Also tried PIO mode but still not detecting discs.Anyone seen this before and found a cure?

  ICF 06:10 25 Feb 05

Do a system restore to a better and happier time

  Fruit Bat /\0/\ 09:45 25 Feb 05

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

Alternative Method—Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.

  ashdav 16:03 25 Feb 05

thanks for that. I'll try it later and post back result

  ashdav 13:18 26 Feb 05

couldn't use the regedit route as I can't see master or slaveIdchecksum. The second method also failed as transfer mode was set to multiword DMA mode2 again not Ultra DMA. Ultra does not appear as an option in the pull down list. Problem is the same as before. any more ideas?

  Fruit Bat /\0/\ 14:28 26 Feb 05

Try the alternative method uninstall the IDE (secondary) that the drive is on and then Action scan for hardware changes and let XP reinstall the drivers.

  ashdav 14:47 26 Feb 05

still goes back to multiword DMA mode2 after closing the window not ultra DMA. Any more ideas (apart from a big hammer). System restore is off so that isn't an option and I don't want to reinstall if I can help it. What about having another go at the regedit route. Where do I find master or slaveIdDatachecksum ?

  Fruit Bat /\0/\ 15:00 26 Feb 05

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002

is normaly the secondary ide channel

open the 0002 folder (key) slaveIdDatachecksum is the very last item on the list.

  ashdav 16:13 26 Feb 05

datachecksum showed up this time. Did as you suggested but no change. I don't think it's the cdrom because it will detect a bootable cd but no other type.

  ashdav 17:17 26 Feb 05

you won't believe this but I think I've sussed it. pukka,commercial discs are detected but CDRs aren't. Disc content doesn't appear to be relevant. Given the lower reflectivity of CDRs my thinking is leaning towards simply dust on the laser pickup. I'll post back later when I've stripped and cleaned it. Thanks for all the info you gave any way. Really useful stuff. Dave

  Qdiddy 23:50 27 Feb 05

Fruit Bat /\0/
ashdav pointed this thread out to me and I was wondering whether your advice will work for HDD as well as optical drives.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…