DMA Problem (I think)

Yesterday I noticed a problem with CD audio playback, which is jerky. This, coupled with the fact that it took an awful long time to install a program and drivers for my new sound card, has lead be to believe that there is a problem with my secondary IDE channel. The jerky CD playback was also a problem when using the on board sound so this is not down to the new sound card.

Looking in the secondary channel advanved options, I note that one of my optical drive is set to 'PIO only'. I have tried changing this to 'DMA if available' but it defaults back to PIO only.

The drive in question used to play CD's without any problems.

OS is Windows XP. Motherboard is Asus A7V333.

Any help would be appreciated.

  SEASHANTY 21:10 11 Aug 03

You could meander your way thru System information to "Hardware resources" and check out which DMA channels are available. Labelled 0 to 7 but No.4 is not available as its used by the system. DMA channels should not be shared. It causes crashes. Your sound card is probably using two channels. Maybe there isn't one spare for your optical drive. If it used to work okay then maybe your new sound card has appropriated the channel that was being used on your optical drive. PIO access is pretty slow but sorry I do not have a clue as to the cause.

Hello Seashanty.

DMA Listing is as follows:

Channel 2: Standard floppy disk controller
Channel 3: ECP Printer Port (LPT1)
Channel 4: Direct memory access controller

There is no mentione of any channels for the sound card or optical drives.

My sound card developed a fault a couple of weeks ago so as a temporary measure, I decided to use the onboard sound before fitting the new sound card at the weekend. Perhaps the problem was caused by utilising the onboard sound although I did not try playing an audio CD with this until just before installing the new card. I thought that the playback problem may have been caused by the onboard sound, which is why I opted to fit a new card.

The other thing I have noticed is that when in the advanced options, the 'auto detection' option is greyed out for both the primiary and secondary channels.

Any other suggestions would be greatfully received.

  DieSse 21:01 12 Aug 03

Playing an audio CD is so slow (the CD runs at 1x only - by definition) - that you do not need DMA to cope with this. The problem lies elsewhere.

Any idea where the problem lies, DieSse?

Interestingly, MY CD ROM drive was set to PIO mode and there was a problem when playing an audio CD. Changing this to DMA resolved the problem.

It's my combined DVD ROM/CD RW drive with which I have the problem so this will probably hamper the speed at which CD's are burnt.

  SEASHANTY 01:28 13 Aug 03

Presume that you disabled the onboard sound in the bios when you fitted the new sound card and that both Primary and slave channels on the secondary IDE controller are both set to "AUTO" in the bios setup.
Also cannot understand why you are unable to set DMA
either as only 3 of your 8 channels are in use.

Hi Seashanty.

The onboard sound is enabled/disabled using a jumper. I'm fairly sure that there are no settings in the BIOS for this as I did not have to make any changes to use the onboard sound. The BIOS is set to "AUTO" for the drives on the secondary IDE channel.

It's strange that the 'auto detection' option is greyed out under advanced options. I could not have possiblu changed these settings because I wasn't even aware of their existence until I encountered this problem.

  DieSse 13:14 13 Aug 03

The reason the playback is "jerky" is probably just the load the systems working under - too many other things running at the same time.

Try by disabling some of the things that are loaded automatically on start up (go to Run and type in msconfig - you will see what's set to start up).

Disable a few things at a time and see if you can find the real culprit.

  SEASHANTY 15:19 13 Aug 03

DieSse is probably right. Checking Device Manager here I find that on the secondary IDE controllers Device 0 (which is my TDK 32x CD-RW drive)
Device type : Auto Detection (greyed out)
Transfer Mode : PIO Only
Current Transfer Mode : PIO Mode

Device 1 (which is DVD-ROM unbranded maker)
Device Type : Auto Detection
Transfer Mode : DMA if Available
Current Transfer Mode : Not applicable

In Device 0 I can alter the setting of PIO Only
to DMA if Available. If I do this then Current Transfer Mode changes to read
Ultra DMA Mode 2.

Thanks for the replies, DieSse and Seashant.

The programs loaded during startup have been the same for sometime now. This, coupled wiht the fact that I am running an XP2000+ with 512MB of RAM, suggests to me that plyaing a CD should not put any strain on the system resources.

The problem probaly stems back to when I changed to onboard sound. I certainly recall playing CD's without any probblem only a week or so before my sound card developed a fault.

Device 0, which is my Ricoh DVD ROM/CDRW drive only defaults to PIO mode even if 'DMA if available' is selected, Device 1, which is my Creative CD ROM drive, is set to 'DMA if afailable' and the transfer rates is shown as 'Muiti-word DMA Mode 2'

When I first discovered these settings, both were set to PIO only.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…