Displaying "fractions" in browser pages

  grumpy-git 06 Jan 10
Locked

I've always used ¼ (alt0188) and ½ (alt0189)in titles in my gallery pages, but have only just noticed they no longer display properly.

It's the same in Firefox & IE.

I've noticed odd characters on pages in other web sites before, but did not know what they were.

Is there any way round this or do I have to revert to 1/2 for half an 1/4 for quarter?

Tried a few searches last night, but couldn't make much sense of what I was reading - perhaps somebody could explain in simple terms for me?

g-g

  beynac 06 Jan 10

You could use the following 'special characters':

1/4 use '¼'
1/2 use '½'
3/4 use '¾'

  beynac 06 Jan 10

The code converted when I posted. I'll repeat iy with spaces.

1/3 use '& frac14;'
1/2 use '& frac12;'
3/4 use '& frac34;'

Remove the spaces after the ampersand.

Hope this works!

  grumpy-git 06 Jan 10

Thanks beynac.

I'll have a go at that later on. Not sure if I've dozens or hundreds of them to alter. Unfortunately it's not a "search & replace" type of operation to sort this problem.

g-g

  grumpy-git 06 Jan 10

?

The above is the character that has replaced my ¼.

I tried & frac14 (without the space) also & # 188 (without spaces) but neither worked.

Then, stupidly I thought at the time, I replaced that character above with my usual "alt 0188" and it worked, the quarter is displayed correctly again.

Just wondering if something funny happened when I changed hosts.

Any ideas how I can search my photo gallery for all occurrences of that character? Entering it in the search field gives no matches.

g-g

  grumpy-git 06 Jan 10

?

More about the above character, in IE it is the outline of square, in Firefox it is a white question-mark on a black diamond.

Spooky!

  Eric10 06 Jan 10

The final semicolon is an important part of the html codes and they don't work without it.
e.g. & frac14; NOT & frac14

  grumpy-git 06 Jan 10

Thanks Eric10, I did try it with the ; but result was the same.

Maybe I'm causing confusion in this, I'm using a Coppermine photo gallery and the fraction is part of the descriptive text, so is not actual .html code.

I also have a phpbb forum which uses fractions & they seem to display correctly. This was also recently transferred to the same host as the gallery.

I looked at the 1/4 fraction on a different computer with Firefox and there were letters within the square, looking like:-

FF
FD

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message