Disk Defragmenter not working

  Lazarus5 16:28 18 Jul 03
Locked

I have been using Diskeeper to defragment my drives but have removed said software now and
want to revert back to windows's own defragmenter. The problem is that an error now pops up saying 'Snap-in failed to initialize'.
Name: Disk Defragmenter.
CLSID:{43668E21-2623-11D1-A1CE-0080C88593A5}.
When ever I try to use it. It would appear
that in removing Diskeeper it has altered windows some how, but I don't know how to get it
back again. I am using windows XP and can't find any reference to this on Microsoft web
site. Can anybody help please.

  Djohn 17:07 18 Jul 03

Have you tried...
Start > Run > Copy and Paste:

SFC /SCANNOW

Click "ok" and have your XP CD already in the drive?

Courtesy of "Powerless" from another thread. j.

  hoverman 17:13 18 Jul 03

I can't imagine why you should want to revert back to the Windows defrag program. The XP version is after all a scaled down version of Diskeeper.

  VoG II 18:02 18 Jul 03
  Lazarus5 13:42 21 Jul 03

Thanks guys but still not got it working. Think I will have to resort to re-installing windows.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…