DISABLING CUT AND COPY FUNCTIONALITY

  boormo 12:08 16 Jan 04
Locked

HELP !!! we have recently intorduced an archive workstation running windows 2000 pro. the aim is to let all users see and open files from the archive machine but also to ensure that they cannot save changes or save as. the share and ntfs permissions are read only. this works fine but users are still able to cut or copy files which defeats the whole object ! is there something i am missing or perhaps a group policy will help, or is there some third party bit of software that can help !

i would love to hear any ideas or suggestions

regards

Andy

  spikeychris 12:20 16 Jan 04

There will be third party progs but is the machine on a network?

  spikeychris 12:23 16 Jan 04

click here if its a standalone and not using AD.

  boormo 12:49 16 Jan 04

the machine in question is a win 2000 pro workstation that is a member of the domain. will your tweak do teh trick in this case ?

i was tending to think down the lines of placing the machine in an ou and the n applying a GPO to it, well, if youcan disable cut and copy etc in a GPO !

  spikeychris 13:05 16 Jan 04

Might be better using the GPO instead of running with the reg hack.


1. Start / Run / MMC / OK.


2. On the Console menu, press Add/Remove Snap-in.


3. Press Add.


4. In the Add Standalone Snap-ins window, select Group Policy and press Add.


5. In the Group Policy Object, select Local Computer and press Finish.


6. Press Close and OK.


7. Navigate through User Configuration / Windows Settings / Internet Explorer Maintenance / Security.


8. Double-click Security Zones and Content Ratings.


9. Select the Import the current security zones settings radial button and press the Modify Settings button.


10. In the Select a Web content zone to specify its security settings section, select My Computer.


11. Press the Custom Level button.


12. Scroll the Security Settings to Downloads and set File download to Disable.


13. Scroll to Miscellaneous and set Drag and drop or copy and paste files to Disable.


14. Press OK, OK, and OK.


15. Start / Run / secedit /refreshpolicy
user policy /enforce / OK.

  boormo 13:07 16 Jan 04

marvellous !!! thanks, that is a huge help !! keep the users of my back !!

i shall sort that early next week and see how we go !

many thanks

Andy Boorman

  spikeychris 13:10 16 Jan 04

Your welcome Andy. Good luck.

  boormo 13:48 16 Jan 04

Hi

when i get to "select a web content zone" there is no "my computer" icon !!

  spikeychris 14:54 16 Jan 04

Sorry for delay, busy day. Is there an "Intranet Zone"?

  spikeychris 15:03 16 Jan 04

Yeah just double checked, use Intranet instead of My Computer.....cus My Computer won't be there....:o)

  boormo 15:06 16 Jan 04

apparently by default you cannot see the my computer icon ! helpful, have tweaked the registry

hkey_current_user\software\microsoft\windows\currentversion\internet settings\zones\0

the Flags value is DWORD value. setting the value in hexadecimal to 47 displays the my computer icon. setting it to 27 hides it !

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

Best Christmas Agency Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…