DHCP enabled router will not assign IP addresses

  lisawe55 18:20 24 Feb 05
Locked

I have 2 computers, both running XP Pro, that I am trying to network using an xMicro broadband router. I am connected to the internet via a cable modem.
I have plugged one cable from the modem to the WAN port of the router. I have also connected cables from each computer's network card to the LAN ports of the router.
When I connect to the URL of the router, it is supposed to get IP addresses for the computers, but it never does this.
When I look at the advanced properties of each network connection, they have IP addresses assigned: Host computer 192.168.1.100; client computer 192.168.0.101

Why are the computers unable to access the internet?

  FelixTCat 19:08 24 Feb 05

Have you set up the router to be a DHCP server? It is one of the setup options.

All the computers must be in the same address range as the router; if the router is 192.168.1.100 then the pcs must be in the 192.168.1.x range, usually following on from the router when x will be 101, 102 etc.

  lisawe55 19:58 24 Feb 05

Not sure how to setup the router to be a DHCP server.

  lisawe55 20:06 24 Feb 05

Another thing: I have been told to set the network connection to obtain the IP address automatically. But when I look at the instructions that come with the router, they tell me to set the IP addresses manually.

  FelixTCat 22:41 24 Feb 05

Exactly what make and model is your router?

  lisawe55 10:09 25 Feb 05

The router is x-Micro WLAN Broadband router.

  FelixTCat 12:02 25 Feb 05

I am presumiong that you have the XWL-11GRIX router.

Unless you have changed it, the router's default address is 192.168.62.1.

Type click here in your browser's address bar and you should get the logon box of the router. If you have changed the router's address, type the changed address in.

The default log-on is admin and password 1234. Once you are in, change the password to something you will remember - write it down.

On the Setup page, set the Lan address to anything you wish (192.168.0.1 and 192.168.1.1 are common) or leave it as it is at 192.168.62.1

On the DHCP page, click the DHCP Server Enable button. If the pool starting and pool ending addresses are already there, leave them alone. They should be in the same range as the router's IP address (ie 192.168.62... (or 192.168.0... or 192.168.1... if you changed it).

Then save the changes and exit.

Make sure that your pcs are set to obtain an IP address automatically and you should be connected.

  Chezdez 12:04 25 Feb 05

i'd have thought that (usually), you leave the network connection to obtain an IP address automatically, and setting the router as DCHP enabled. this should be an option somewhere within the router. then set the comps to auto-obtain an IP and you should be sorted

  Forum Editor 23:31 25 Feb 05

You're right.

Normally the router would have DCHP enabled by default, and in fact that's often the cause of problems when people are running a separate ADSL modem, which may also have DCHP enabled. You can't have two DCHP-enabled devices on the same network, and many networking problems stem from this - people don't realise that they need to disable DCHP on one of the devices.

In a home network the computers can be configured to obtain an IP address automatically, and the router will handle the rest.

  lisawe55 19:00 26 Feb 05

That may indeed be the problem, the fact that I have a cable modem which is probably also DHCP enabled. So you think I should disable this feature and fill in the computer IP Addresses myself on the router's home page?

  lisawe55 19:25 26 Feb 05

By the way, the URL to the router's setup page is actually 192.168.1.254. It brings me to a "status" page where the router is trying to obtain the "DNS server"- but it never actually manages to do this.

This thread is now locked and can not be replied to.

Amazon Fire HD 8 review: A brilliant combination of function and value – with one massive caveat

1995-2015: How technology has changed the world in 20 years

How to create an introvert-friendly workplace

Apple Watch Series 2 review | Apple Watch 2 review: New Apple Watch is faster, brighter,…