DG834G Home Networking

  westglenn 21:40 23 May 08

I have three computers, two desktops and one laptop. Desktops are wired connection, laptop is wireless.

My ISP is AOL. I have had no connection issues and like the DG834G but I am struggling to setup home networking.

All computers are running XP.

How do I configure the home networking?

Is there something I need to disable?


  mgmcc 22:39 23 May 08

Basically set any folders that you want to have available over the network as "shared" by right clicking and selecting the Sharing & Security option. At least one folder in each PC should be "shared" to get them communicating. Ideally all computers should be in the same Workgroup (although XP does support multiple Workgroups) and any firewall software should be configured to allow access to the networked computers, which may involve adding their IP addresses in a "trusted" section.

  westglenn 09:47 24 May 08

Thank you for response.

It sounds like it might be a firewall issue, as the work group name is the same.

How do I confirm each computer's IP address?
Do I use ipconfig /all to obtain IP address?

I have McAffee firewall on one computer and Zone Alarms on the other.

To add a further question, if I want to expand the number of wired ports available on the network could I add a Netgear FS605 or FS608 switch?

  mgmcc 15:18 24 May 08

As you're using a Netgear DG834G, its own IP address is so, to configure Zone Alarm, click the Firewall tab at the left and then the Zones tab at the top. Click the "Add" button and select "Subnet", type in:

IP address -

Subnet Mask -

Description - {anything} but it needs an entry.

Click "OK" and, back in the main window, click "Apply". Minimise Z.A. back to the System Tray.

By using the Subnet address of instead of individual addresses, you're allowing access to all addresses from to so it doesn't matter if the router's DHCP server allocates a different IP address to a particular computer. McAfee should have a similar option - I seem to recall configuring it once for someone and it actually used the subnet's 'broadcast' address of to allow access to the full range.

Plugging a network "switch" into one of the router's LAN ports will give you additional ports and the router will still allocate IP addresses to any additional computers connected via the switch.

  westglenn 22:31 24 May 08

Thanks for your help.

That worked perfectly. Just wanted to leave closure for others search in the forum.

To change McAfee you goto Options, then Trusted IP's. Add the and tick the "Make all the computers on you LAN Trusted." Finally, click ok.

No need to reboot.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…