Device Manager folder empty

  swapper 19:59 16 Jul 05
Locked

WinXP HE.
I have found that the Device Manager and the Network connections folders are empty, the PC is running o.k.

I have run Scannow and chkdsk
any ideas please?

  swapper 20:25 16 Jul 05

^

  woodchip 20:26 16 Jul 05

Have they been hidden by Administrator

  swapper 20:48 16 Jul 05

woodchip, thank heavens your here :-)

I am the administrator, but how could I hide them??

  sattman 21:08 16 Jul 05

I dont use XP but found the following that may resolve your problem.

"The issue is security permissions in the registry. I cannot tell how they are lost
but I can tell you how to fix it short of having to re-install Windows!

You must use regedt32.exe in Windows 2000/XP (as I have not seen this problem posted
for any other operating system). Be very carefull making changes in the regisrty!

You must be logged on as a local administrator to perform this task:

1. Go to "Start", "Run", and enter "regedt32"
2. Maximize the "HKEY_LOCAL_MACHINE" window.
3. Scroll down to "SYSTEM\CurrentControlSet\Enum"
4. With "Enum" selected click the "Security", "Permissions" menu.

Note: At this point you will probably notice there are no permissions on this key.

5. Click "Add".
6. Add the group "Everyone" and the user "SYSTEM".
7. Select "Everyone" and check "Read" ONLY!
8. Select "SYSTEM" and check "Full Control".
9. Click the "Advanced" button at the bottom of the window.
10. On the Advanced window check "Reset permissions on all child objects..."
11. Click "OK"
12. On the warning window click "Yes"
13. Close REGEDT32

You should now be able to see everything in Device Manager, Network Places Properties,
and Printers."

Good luck.......................

  swapper 21:22 16 Jul 05

sattman, thanks for that, I will have to wait until tomorrow now, my wife has just taken over?????????

  swapper 08:30 17 Jul 05

sattman, I followed your pathdown to System\CurrentControlSet\Enum, but within Enum. there was not Security.
I found HKLM\Security. right clicked Security, found Permissions, within that I saw Administrators\Full Contol\read - Everyone\Read -Syste\Full Control\Read.
In the Advanced box the two options - 1.Inherit from parent the permission etc. 2.Replace permissions entries on all child objects etc. were unchecked. I checked the replce permission entries on all child objects etc. checked the yes as you suggested, then apply, at this stage I got the message "Registry Editor could not set security in the key currently selected, or some of its subkeys.

Any ideas pleeeeeeease??

  swapper 08:32 17 Jul 05

I have just remembered that I did use CCcleaner a while back, and I was not sure what I did, could this have some bearing on the problem?

  VoG II 08:43 17 Jul 05

Have you tried System Restore?

  swapper 16:35 17 Jul 05

VoG™, sattman, woodchip, I did a restore back to a month, I am now back to normal, thank you for your imput.
Would ccleaner have caused this problem if I have used it incorrectly?

  sattman 18:09 17 Jul 05

Good to hear you solved the problem, ccleaner is usually pretty selective but whenever you make changes of any sort in your system you can never be certain, that is why a backup or sys restore is a must.

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

iPhone 9 and beyond: 32 amazing future smartphone developments - graphene, supercapacitor…