DeveloperSide.net version 1.5

  badgermansix 06:59 16 Jan 06
Locked

Reading the small print, I am certain that it said "for beginners and etc......"

So! am I past my sell by date?
I downloaded "DeveloperSide.Net Web-Server Non-SSL Pakage, version 1.15

This is now on empty d: drive:- d:\www
To be on the safe side, I uninstalled ZA (not happy about that).

I then printed off:- Instructions - Set up the enviroment.
Then I see..

Item 2.Edit \www\my.ini
edit the following fields to to reflect the corect drive.
There is no my.ini. showing in the www page.

Under "Client" and "mysqld" sections was o.k.

I could not find "basedir=d:/www/mysql or datadir=d:/www/mysql/data/

Item 3
I could not find \wwwphp.ini, or doc_root, or extension_dir.

and that was just the start:-(
what am I missing (besides brains)?

  Taran 20:57 16 Jan 06

The only thing you're missing is the experience of having done this before.

A very brief breakdown of how to install the Devside server kit is this:

Unzip to destination drive (your C: drive is best otherwise you'll have to start manually editing the config files) and this assumes that you downloaded one of the compressed archives and not the self-installing executable.

Open up the www folder that unzipped to the destination drive.

Copy the my.ini and php.ini files to C:\WINDOWS

That last step assumes that you unzipped the server kit to C:

If you unzipped to another drive we'll have to get creative.

Add this to the end of your Environment Variable Path

;C:\www\Apache2\bin;C:\www\php\dlls;C:\www\mysql\bin;C:\www\perl\bin

Restart PC

Open up a command prompt andtype these commands, hitting Enter after each one - note that you can copy from here and paste into a command prompt window:

cd

cd www\apache2\bin

apache -k install

net start apache2

cd
cd www\mysql\bin

mysqld-max-nt --install

net start mysql

That's the base installation done, remembering that you have to press Enter after each of the above.

All that's left is to lock down MySQL a bit (not essential at this stage) and possibly to add the username of root into your C:\www\phpMyAdmin\config.inc.php file.

If that sounds like a major headache, it isn't really.

If you get badly stuck, ask for help. If you need it I can configure the whole lot for you, put it on a server for you to download and write out some simpler instructions to get you up and running.

Installing/configuring on D: will cause issues unless you manually edit the two .ini files.

I'm happy to help with this if required, but don't think it's hard- it's just very, very different to most people's expectations and experience.

T

  Taran 21:01 16 Jan 06

Everything is hard until you know how it's done...

Try not to get discouraged - this is difficult stuff compared to point and click installers, but it still isn't hard, just different.

  badgermansix 06:53 17 Jan 06

Thanks Taran,
its 0615 Tue, and I do have to go out very soon, just thought I would have a quick look for mail.

I think I am getting there now, as I said, I printed off the Instructions to set up the Enviroment, and have doing the tests etc.

BUT - forgive the shouting - I can now work off line!! with these, a massive break for me!

I am too embarrassed to say what I think that I was doing wrong now, I will tell you later.

And thanks for your kind offer to help.

  Taran 17:47 17 Jan 06

Fingers crossed that you are now a fully fledged Apache, MySQL and PHP nugget like the rest of us crackpots...

  badgermansix 22:23 17 Jan 06

Taran,
Excellent news ! ...Almost.
after I mailed my last, I carried on following the instructions etc. and came up against this:
I followed:-

(At the very beginning of the installation I had a problem with "my.ini", could this be the result?
when I went to install MySQL as a service:

\www\mysql\bin> mysqld-max-nt --install
I got the message:

The service already installed!
The current server installed: D:/mysql/bin/mysqld-nt.ex.)

Anyway, after my mail I did this:

(test MySQL)

d:\www\mysql\bin> mysqladmin -u root status

and got the message:

MySQLadmin: connect to server at localhost failed.
Error: Can't connect to MySQL server on "localhost<10061>
Check that MySQL is running on localhost and that the port is 3306.

Went to telnet localhost 3306

Got message; telnet could not open connection to the host on port 3306
*****

I have edited my.ini under [mysqld]
immediatley under mysqld
I have added "bind-address=127.0.0.1"

Any advice please?

  badgermansix 14:51 18 Jan 06

^

  Taran 17:13 18 Jan 06

Your problems are probably due to incorrect editing of the file.

The Devside bundle lives by default on the root of C in a folder called www

Inside the my.ini and php.ini files are references to file locations on C: sincemost people would use that as their default.

Example, taken from the my.ini file:

basedir = C:/www/mysql/
datadir = C:/www/mysql/data/
port = 3306
socket = C:/www/tmp/mysql.sock

To work from D: all instances of C: must be changed to the letter of the drive you installed to, which in your case id D:

It's much simpler to just drop the www folder onto C: and go from there with the default my.ini and php.ini files. No fooling around with them required.

I'm still a bit stumped as to why you put it on a separate drive to begin with. To work at all from any drive other than C: some careful editing of the two .ini files is required as well as a bit more jiggery pokery.

Keep in mind that the additions to your Environment Variables Path will also have to reflect the location of your files on D: and not on C:

So instead of adding this to the Environment Variables Path:

;C:\www\Apache2\bin;C:\www\php\dlls;C:\www\mysql\bin;C:\www\perl\bin

You'd have to add this:

;D:\www\Apache2\bin;D:\www\php\dlls;D:\www\mysql\bin;D:\www\perl\bin

And that would only work with very careful editing of both of the .ini files.

I think you've given yourself extra work by putting things on a drive other than C:

Have you considered removing MySQL, PHP and Apache and installing from C:, or you could just download and install the self installer version of the Devside bundle ?

Net stop MySQL

Net stop Apache2

\www\mysql\bin> mysqld-max-nt --remove

\www\Apache2\bin> apache -k uninstall


Delete the my.ini and php.ini files from C:\WINDOWS

Delete ;C:\www\Apache2\bin;C:\www\php\dlls;C:\www\mysql\bin;C:\www\perl\bin

or

;D:\www\Apache2\bin;D:\www\php\dlls;D:\www\mysql\bin;D:\www\perl\bin

from your Environment Variables Path.

If this seems radical it's because I set this bundle up for people in about three minutes from C: without having to edit a darned thing or bind MySQL to any particular address.

I know how simple it can be, once you know your way around, but I also appreciate how difficult it is for the first time, and especially so if files that are referencing C: in them are living on D:

Just to complicate matters, nothing in the above makes any difference if your main had drive is, in fact, D:

  badgermansix 18:23 18 Jan 06

Taran,
You are correct about C drive.

The only reason that I put it on D drive was because my system is running o.k. at the moment and I did not want to mess up C drive.

However, after all of the information that I have received from you, tomorrow I will uninstall from "D" and reinstall to "C"

I did download seup 1.5 from devpac.

And to tell the truth I have resolved the last problem that I had.

"I have edited my.ini under [mysqld]
immediatley under mysqld I have added "bind-address=127.0.0.1"

I removed it to the bottom of the list of [msqld].

Nevertheless, I will do as you suggest and install to "C" and as McArthur said "I shall return" :-))
thanks again.

P

  Taran 21:15 18 Jan 06

In fairness to you, if all is working as expected then you could always just do the sensible thing here and leave well alone.

If you have a working local server where you have tested Apache, PHP and where creating, reading from, writing to, or otherwise manipulating a MySQL database works as expected, it would make sense to leave well alone.

The above post was based on the fact that you had indicated a problem.

If you have no problems now, just leave it alone and use it.

T

  badgermansix 07:54 19 Jan 06

Taran,

And this has taken me two weeks...

I did as you suggested, put it on "C" drive and it went on like a dream. thank you, thank you, thank you.

Three very small points?
1. I am hesitant about changing the passwords, I tried it twice, and had to uninstall/reinstall.
I see on the "phpMyAdmin" page that there is an option to change password, should I do it from there?
2. I uninstalled ZA (after reading the small print on the Apache information page) can I reinstall without problems?
3. Every time I change to a another page, I get the option to "connect" "cancel" or Work offline" is this normal.

I am Certain that the help that you have provided me in these threads will be of great value to other beginners.

All(?) I have to do now is learn how to use the programmes :-))

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

The Pantone Colour of the Year 2017 is Green

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…