Dell PC Boot problem

  srwpchelp 21:27 21 Oct 10
Locked

Hi,

My Dell PC will no longer boot up when I switch it one. It hangs on the Dell boot up screen and eventually says "no boot device available".

However, if I switch the PC on, press the "Setup" or "Boot Options" key during boot up, wait for the relevant settings screen to appear & then press (for example) the "Escape" key, the PC boots up fine.

Once windows is up & running, if I do a re-start then the PC re-boots without a problem.

Any idea as to what the problem might be?
Incorrect BIOS settings?

Thanks,
Steve.

  MAT ALAN 21:35 21 Oct 10

click here

some things to look for first...

  srwpchelp 23:39 21 Oct 10

Hi Mat Alan,

I had a look at the link that you provided. Thanks.

1. Connections are OK
2. No USB devices are attached (except the keyboard, modem, wireless mouse and printer).
3. Device priority is DVD-Drive then Hard Drive.
4. Vista Start-up Repair showed no problems.
5. No new Hard Drive added.

It's strange that the PC boots up OK if I go into "Set up" or "Boot Options".

  srwpchelp 06:38 22 Oct 10

If I wait until the "no boot connection" screen appears and then press Ctrl+Alt+Del, the PC boots up fine. Very strange.

  MAT ALAN 07:54 22 Oct 10

Have you tried setting your boot option to HDD first.

Have to say this issue has been known to be linked to a failing HDD.

you could try a memory test
click here

  srwpchelp 08:31 22 Oct 10

I've already tried both of your ideas.
Sadly, they made no difference.

It seems strange that everything is OK (i.e. no HDD problems) once Windows has loaded.

I'm backing data up daily just in case it is the HDD.

  Fruit Bat /\0/\ 15:04 22 Oct 10

As drives get older, they can take longer to get up to speed and become ready (available). This can then exceed the time it takes for the booting to look for the drive - so it doesn't find it.
The solution is often to make the initial part of the boot take longer, by disabling "Quick power on self test and/or making the system look for the floppy drive first by enabling "floppy seek".
Some BIOS even have a facility to put in a delay before the hard disk is checked.

  birdface 15:25 22 Oct 10

Pressing Ctrl+Alt+Del used to be a way of signing in on some computers.
Try the BIOS and disable anything for floppy at start up.
I had to change mine to run from DVD.
I hope thats right as it was a while ago and it was an oldish Dell.

  srwpchelp 22:08 22 Oct 10

The problem is getting worse. I'm now getting hard drive failure messages. However, when I do manage to boot up, the PC is fine.

I tried the boot up option suggestions. No difference. I can't disable "Quick Power On".
Doens't appear in the BIOS.

My PC is only 18 months old !!

  birdface 22:52 22 Oct 10

I dont suppose a system restore to a point when it was working Ok would work.

  birdface 22:57 22 Oct 10

Or maybe try device manager to see if there are any yellow exclamation marks beside any of the disc drives.

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Framestore’s haunting post-WWII title sequence for new BBC series SS-GB

How to install MacOS Sierra on an older Mac: Get Sierra running on Macs & MacBooks from before 2009