Delay for text to appear on screen when typed

  Mjones68 08:16 18 Jan 08
Locked

Hi Could someone please help us with a very annoying problem. My wife and I upgraded our laptops last month and each purchased a Dell Vostro 1500 with windows XP Professional. We then installed our Microsoft office products (I’ve 2002 and my wife has 2003). The machines came with McAfee and we both also use ‘ccleaner’ and ‘ad-aware 2007’ to keep the machines ‘clean’. My machine works great, however there is a very annoying delay when typing on my wife’s machine, in that it takes a split second for the text to appear on the screen after typing. Unusually, this does not happen all of the time and when it does, it tends to be when typing things into google, although it’s also happened when typing into a word document. I’ve googled this, but the search didn’t come back with a solution and it’s now starting to drive us nuts. Any help would be very much appreciated. Thanks

  Demora 08:41 18 Jan 08

Try the control panel/keyboard/speed tab. You can test the repeat rate of the typing and speed it up here

D

  Obsessed 02:20 02 Feb 08

Mikey, I am wondering if the control panel/keyboard/speed tab setting worked for you. I too have a new Dell Vostro 1500 (a Christmas present for my kids), with windows XP and have the same symptom of a typing delay. I have searched for clues, and mostly the suggestions are that there could be mal-ware or a virus - though McAfee finds nothing, adware does not help and RegCure also does not help, and this was happening pretty much out of the box. Watching the windowns task manager while typing, the CPU usage never goes above 14% yet at times there is a delay of as much as 4 or 5 seconds (and sometimes no delay). With 1.6 Ghz Intel Core 2 Duo, 2 GB Ram running XP this system should scream - any ideas what might be going on?

  Mjones68 09:33 03 Feb 08

Hi, Obsessed, thanks for contributing to our discussions on this problem.

I checked the Control panel/keyboard/speed tab but the settings were exactly the same on both machines (my wife’s and mine) so I don’t think that it can be this, as my machine works perfectly. It’s very useful having bought two exact machines at the same time, with only slight differences in what’s installed on them (Office 2002 or mine and 2003 on my wife’s) but in a way this just adds to the mystery and I’m just not getting to the bottom of the problem. I checked with Dell and they advised installing a new BIOS on each machine, which I’ve done, but it’s not fixed the problem. Also, we’ve found that the microphone/sound recording on both machine is terrible (especially noticeable with the likes of Skype) and I was wondering if you’d also had problems with this. The sound keeps coming and going on our machines?

  Gongoozler 09:45 03 Feb 08

I don't think this has anything to do with the keyboard settings. It's more likely to be something the computer is doing in the background that is taking up processor time. Click Start - Run. In the dialogue box type the word msconfig, then click OK. Click the Services tab, then put a tick in the "Hide All Microsoft Services" box. Then Disable All and OK out of the dialogue box. Restart the computer, ignore the warnings about having used the System Configuration Utility. Be careful because you will have disabled your Antivirus and Firewall. Now see if the computer behaves better. Re-enable the services in the System Configuration Utility a few at a time until you find what is causing the slow-down.

  Obsessed 03:58 04 Feb 08

Gongoozler, thanks for the suggestion. I did just as you outlined and the typing delay continued in MS Word. I have enabled McAfee services but left pretty much everything else disabled, and the delay persists while typing this note. I ran the full "security tango" earlier this evening. At this point I am pretty confident that the system is clean of viruses, spyware, adware, etc. Any other suggestions?

  notsosavy 22:06 11 Feb 08

When I saw your postings, I had to register to register on PC advisor to share my scenario. We got a new Vostro 1500 last month. Out of the box there was a typing delay. I called customer service (and have been VERY unimpressed with the hold times at Dell). They did exactly what Gongoozler suggested. They turned off everything running in the "background"" and the problem cleared up. When I made other system changes, though, the problem came back. I was within the 3 week return policy so I had a 2nd vostro 1500 sent to us and I returned the original. I am now using the new 1500 and there is a typing delay on this one, too. I am tempted to return this one and just start over looking for a new laptop. At this point, I don't know if I'm jumping the gun on this but I am very dissatisfied with this and I havespent literally hours on the phone with customer service. Your thoughts? I feel your pain.

  Obsessed 03:20 13 Feb 08

Hi notsosavy,

I am happy to report that my problems were just solved by Dell technical support. I used the dell chat session to explain my problems last week. This did not lead to a solution, but did run through a number of diagnostics. When I reported back tonight, the representative had a solution ready right away.

Click Start - Run. In the dialogue box type the word msconfig, then click OK. Click the Start-up tab. Scroll down until you find "PCMServices", and uncheck the box. Then restart your computer. This completely took care of the problem for me.

  notsosavy 01:59 22 Feb 08

Hi Obsessed.

I wanted to thank you for your advice. I did go to the startup tab and unchecked pcmservices. Since having done this, things seem to be fine. I appreciate the help and I'm grateful to have found this thread of conversation about it. Many thanks.

  Mjones68 08:07 22 Feb 08

Hi Obsessed,

I originally asked the question and have been following all of the responses and I would also like to say a very big thank you, as I followed your advice and since then, the machine has been working perfectly. Fantastic!!

  Hammar 16:35 13 Apr 08

You are the BEST! I've been messing with this forever! What an easy fix for such an annoying problem. I also thank you!

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…