Dead Motherboard?

  Bilbo63 14:51 08 Oct 06
Locked

I've got this PC that appeared to be 'dead'. Plugged in and nothing happened.

Put a different PSU in and now at least the PSU fan starts and the on switch lights up, but nothing else. None of the usual startup noises (beeps, hard drive activity etc).

I have checked all the connections are firmly in place and the right way round.

Does this sound as though the motherboard has died, or is there something else I can check?

I'd be grateful for any suggestions

  AndySD 14:56 08 Oct 06

Both RAM and Graphics cards can cause this as well. Thy taking them out and then reseating them as this can clean the contacts.

  Bilbo63 16:02 09 Oct 06

Thanks for that Andy, but still no luck.

Anyone got any other ideas, or is it time to call it a day?

  Technotiger 16:12 09 Oct 06

Hi, maybe not the mobo, could be the harddrive?

Cheers.

  Fruit Bat /\0/\ 16:16 09 Oct 06

4 pin plug in next to CPU?

CPU inserted correctly?

  it_girl 16:31 09 Oct 06

Connect absolutely nothing inside the case(ie hdd,floppy nor opticals).Reset Cmos jumpers.
Got the board id?

Now is there anything on the display?Is it on-board graphics,Pci card or Graphics card.
Remove all the ram - any bleeps?

Could require a lovely flashing of the Bios! but later for that.

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Apple MacBook Pro with Touch Bar review

Best iPhone games 2017 | Best iPad games 2017: 162 fantastic iOS games that you need to play right…