Data recovery from USB

  wky 16:25 18 Mar 08
Locked

Hi,

Hope someone can help, basically my work was saved on a usb stick and before it was fine, but now it only shows up as a removable inaccessible drive when I plug it in. basically it is corrupted as I have tried it in many different ports. I'm using Windows XP Home and even tried plugging it into Ubuntu station but it says drive not mountable. I was hoping there was some kind of data recovery software, preferably free, don't mind paying a little bit either. Was hoping someone had some experience, I have heard there was hopes using a linux workstation, but it looked quite technical.

Thanks for any help

  Fruit Bat /\0/\ 16:44 18 Mar 08

From cfc msticks smartmedia etc.
Smart recovery click here
zero assumption click here
Restor Pen Drives click here

  wky 16:54 18 Mar 08

i have a few programs, but all of them say can't find any pen drive...anything else I can do? And I can't format it either and recover the data after.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…