D-Link USB hub

I have an XPPro laptop with SP2. I cannot get to several units via the D-Link usb2 hub, scanner, modem, but flash drive and printer (i3000) work OK. I suspect this is a driver problem and if so whee can I get a new one? Any ideas?

  LastChip 17:03 26 Nov 05

Normally, manufacturers offer up-to-date drivers and a knowledge base for solving problems such as these.

Have you tried?

Do these item work OK when plugged directly into the computers USB port?

I have tried looking for a D-Link site with drivers but had no luck. The device came with no drivers! I have tried the control panel 'update drivers' and this seemed to change the driver (from the web?) but no change. I think the divers I have cannot manage input from devices connected this was because every thing works when plugged into the motherboard USB. E.g. my printer may report 'not responding' but still prints.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…