D-Link DSL200 ADSL router, OSX and USB 2.0

  Production ed 13:10 21 Nov 06
Locked

I use Mac OSX on a G4 PowerBook, and a D-Link DSL-200 router on a BT line administered by Pipex. It worked absolutely fine at my previous address, but the new account on the old equipment barely works at all. Initially it connects - slowly - but then it won't ever allow me to browse to a second site and, in effect, crashes (although the router stays alight, and as far as Pipex and BT are concerned, I'm still online). Whichever browser I use freezes, and then Internet Connect gives me the message: 'The connection was terminated by the remote site. Please try again'. When I try again it fails to connect saying: 'Could not negotiate a connection with the remote PPP server. Please verify settings and try again.' BT have checked the line to exhaustion, and found no problem. There are no firmware or driver updates, and my PowerBook works fine when connected to the network at work. Is it possible that the fact that this router uses a USB2.0 connection is to blame? I don't want to shell out for a new ADSL wireless or ethernet modem, only to find that I have the same problem. Any ideas?

  rawprawn 13:51 21 Nov 06

Have you tried reinstalling the D-Link software?

  Production ed 14:25 21 Nov 06

Yes. I downloaded it from the D-Link site, and (for good measure) I also reinstalled from the original disc.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…