D-Link DSL-G604T New Firmware Woes

  dogbreath1 16:59 11 Nov 08
Locked

Had a few problems with poor and intermittent connectivity (referred to click here).

Sadly, the one swallow didn't make a Spring and the problem continued.

After further digging, I concluded it might be a router problem. The problems started after a firmware upgrade.

I again tried a new upgrade, as before, from click here==, and followed the instructions on installation from click here==.

Problem is, when I get to Step 4 (installing the FS file) my browser (Firefox) loses connection to the router giving the message 'Connection Interupted'.

The initial attempt at an upgrade was not from the principal PC on the three PC network but was over an ethernet connection. That PC is one of the two with dodgy connectivity. My current attempt is from the principal PC, again using an ethernet connection.

Further details on the previous thread linked to above.

Help!

TIA,

db.

  skidzy 18:10 11 Nov 08

I had the exact same router for a couple of years.
I did start a thread regarding my dropout connection,after resetting the router and playing with the settings from the configuration pages-i still had problems.


I could not fix the issue,and one particular PCA member suggested the router just got to hot,this i now tend to agree with.

Now a new router (Belkin N series) and all is fine.

Upshot is,in my opinion the firmware update will not solve your issue. I think the G604T has a life of a couple of years and thats it...sorry.

For now and if possible i would reset the router to factory settings if the firmware has not installed.

  dogbreath1 20:41 11 Nov 08

Thanks for that. I will try to restore factory settings....just hoping (as I had suspected) that the firmware hadn't installed properly first time round.

Will post back with the results.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac