D-Link DI-624+ Stuck in Crash Recovery

  PalaeoBill 23:23 20 Jan 07
Locked

PC cabled to router via RJ45 into Port 1.

Cycle the power to the router:
Network connection drops & re-establishes every 2 to 3 seconds.

Hard reset of router:
Network connection comes up & stays up.
Browse to 192.168.0.1 expecting to get login screen but get Crash Recovery screen instead.

I have tried sending the latest firware to the router (via the Crash Recovery sceen), it appears to send and the router resets but then comes straight back to the Crash Recovery screen.

The router is a revision A3 & labelled Firmware 1.8.
I would appreciate any ideas and/or a URL for the 1.8 firmware download.

  BH34 09:20 21 Jan 07

There are multiple revisions of the device. Please select the hardware revision of your device. click here

  PalaeoBill 10:42 21 Jan 07

Hi BH34

It is an Ax (specifically an A3). I have tried the firmware from this site, which is at version 1.23, to no avail

The label on the underside of the router says firmware version 1.8 and I thought it would be worth trying this if anyone knows where it can be downloaded from.

I suspect the rom is fried but I am loath to give up yet.

  PalaeoBill 09:41 23 Jan 07

Given up. Consigned unit to trash.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…