D: drive has disappeared

  TommyRed 15:57 11 Jan 05
Locked

The kids mentioned our D: drive was being selective about which DVD's it would play last week, it's a DVD-ROM. Yesterday I plugged in my new MP3 player, thanks to the January sales, and it's drive was now D:, there is no drive for the DVD-ROM. Is it knackered or can it be saved? My OS is XP home and I also have a CD-RW. TIA TR

  Technotiger 16:20 11 Jan 05

Hi, have you looked in MyComputer>Properties>Device Manager to see if it shows up there?

  TommyRed 17:39 11 Jan 05

Hi, just checked device manager and it is disabled and will not allow me to enable it, is it defunct? TR

  FelixTCat 17:54 11 Jan 05

TommyRed

Is the MP3 player external and USB? If so, first, remove the MP3 player and reboot. Is the DVD player visible and active? If not, check that the power and data cables are connected properly.
Have you checked that the drives are properly set up as master and slave - 2 master drives on one cable will not work.

Go to Control Panel - Administrative Tools - Computer Management - Storage - Disk Management and look at the drive letters. It is normally good policy to have your removable drives as drives Y and/or Z so that putting USB storage on does not disrupt drive lettering. Change the drive letter by right-clicking on the drive description. The change is immediate and does not require a reboot.

Let us know if this cures the problem

  TommyRed 18:05 11 Jan 05

Yes the mp3 player is external and USB. Haven't checked the cables but I will in the light tomorrow. I haven't done anything in the tower, other than extra RAM months ago, so I assume the master and slave settings are ok. I also went into disk management as you suggested, my DVD-ROM drive D: is not there. There appears to be power to it and the drawer opens and light comes on. TR

  roy 18:39 11 Jan 05

I would check your ide connection, both to the drive and to the motherboard. You may need to remove and replace each connector (firmly) to be sure.

  Fruit Bat /\0/\ 18:53 11 Jan 05

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

Alternative Method—Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.

3. Driver is not intended for this platform
If you keep getting the following error message:

There is a problem installing this hardware.

IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

then the way out is to rename C:\WINDOWS\system32\drivers\atapi.sys (or a similar path on your computer) to something like atapi.old.

If that's not possible, you can try it from the repair console (boot from the Windows install CD and select the repair console).

If Windows always automatically recreates atapi.sys, you can try renaming it in safe mode or from a command line window or you can try to rename or remove it in the driver cache as well.

Desensitize Your Computer's IDE Channels
There's a bit more to it. The following article offers a way to reduce the incidence of this problem, although it still doesn't solve it altogether.

IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur
click here

Do read this article because it contains a useful long-term workaround. But you have to go through the procedure described here to re-enable DMA first. Assuming you've done that, insert the ResetErrorCountersOnSuccess registry values mentioned in this article into both the primary and the secondary IDE port registry keys as described.

Unfortunately this is only a half solution, because when you enter an unreadable DVD, you will get 6 errors in a row, and the IDE channel will revert to PIO mode, but at least when you pull out the DVD in time and then insert a good one, the error counter will be reset and it will at least be a bit more difficult for Windows to hobble your IDE drive.

  FelixTCat 19:13 11 Jan 05

TommyRed

One last simple check. Go to Device Manager and uninstall the D drive. Then reboot. XP should "find" the drive on rebooting and "Install the new device". Hopefully, this will reinstall the drivers if they had become corrupt and the drive should reappear.
By the way, if you have a CD/RW, what drive letter does this show as?

  TommyRed 20:49 11 Jan 05

The Cd-Rw is E:, will try yours and Fruit Bats solutions a bit later and report back, wifes on nights so I've got to do the ironing. TR

  TommyRed 23:43 11 Jan 05

Tried the uninstall and the drive re-appeared in 'My Computer' but still wouldn't play. Went to device status and it reports the drive working ok. Could the kids have changed a setting? TR

  FelixTCat 14:04 12 Jan 05

TommyRed

When you say "wouldn't play", do you mean autoplay, i.e. starts to play when you put a fresh disk in? Try putting a fresh cd/dvd in and opening it (the dvd, not the drive :) ) and try to run one of the programmes on the disk (a music cd would be a good test). If it works, then autoplay has been switched off. Personally I keep autoplay switched off anyway.

If you want to switch it back on, right-click the drive in My Computer and go to the Autoplay tab.

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…