Creative Sound Blaster cards

  fazer 11:58 26 Aug 09
Locked

Thought I would share this information with you all ....

Introduction:
Recently bought a Creative sound card which initailly worked fine including all associated software (THX, mode switching etc)until I used its "auto-update" module and downloaded the latest versions of drivers and software components. Then everything went pair-shaped - could'nt launch any of the software, received various error messages etc and could'nt re-install off the CD. So the next several days spent hours trying to work things out (Creative were useless in that there was nothing on their site that suggested a fix) but one thing I did learn after reading numerous other forums, is that my problem was not unique. At the same time nobody seemed to have an answer! - hence this post.

So, here is a copy of the message I sent to Creative's Help Team:

Thank you for your reply. My card was bought retail with an installation CD - Sound Blaster X-fi titanium.

I have now fixed the issues using a method not listed or suggested by Creative - and I think you need to know about it because after reading numerous internet forums, my problem was not unique ......

The issue I had was that the software was unable to launch after using your update software with various messages displayed stating that components were missing and the card was not recognised. They all suggested re-installing off the CD but this did not work.

When I updated I only chose to update the most recent versions (ignoring previous versions of the same software) which is the logical and correct thing to do when updating anything - which is when the trouble started. But when I let the software do its thing and downloaded all versions (letting it install then uninstall several times) all was well. This obviously suggests that one of the RECENT versions is corrupt or for whatever reason, some component is removed - so when installing all the older versions as well, it is replaced somewhere back along the line.

May I strongly suggest that Creative gets its act together and only post working updates or at the very least suggest to the end user that they should not only download the most previous versions of its software but download everything. This method takes ages, is totally illogical and is contrary to every other software Company in the world but at least it is quicker than the several hours it took me to sort your mess out.

  sunnystaines 12:28 26 Aug 09

with more pc screens going hdmi with graphic doubling up with sound. sound cards will be on their way out soon.

  citadel 14:51 26 Aug 09

I have a creative card and it works ok using the drivers that were on the cd, never updated in the 3 years since I got it.

  Graphicool1 14:52 26 Aug 09

.
I have WinXP SP3 and Creative SB Audigy Platinum. I was intending to install the latest SB driver update. Until I read that if I do and then decide to update to Win7 all the sound blaster extras will stop working. I don't know wether it's a problem with Win7 or Creative. Either way, I've decided to give the update a miss for now. After all it's working ok. Not that I was or am intending to go with Win7 in the forseeable furure.

Mind you if I or anyone else had installed this new driver and decided to give Win7 a try, have no fear, you only have to roll the driver back.

  Stuartli 14:57 26 Aug 09

Many years ago I had a Creative Soundblaster Live! card - Creative's support was just as chaotic then....:-)

Only one particular members of the support team who would take up issues in the company's forums had any real nouse about any steps to take.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

Where HTML5 is headed next

MacBook Pro v Surface Pro 5