Creative 3D Blaster 4 Titanium 4600 & Directx 9.0

  DeFuNkT 16:44 09 Feb 03
Locked

I'm running the graphics card mentioned in the title on the following machine:

P4 2.2ghz
512mb DDR
Windows 98 Second Edition

I had Directx 8.1, but my graphics card didn't seem to be running up to spec, pretty much no different to the 32mb GF2 I had in. So I upgraded to Directx 9.0 and still no noticeable difference. One of my games has a patch to work properly with Directx9 so I figure my other main game (Mafia) might not be set to run properly on Directx9.

I can see only 2 options. Upgrade my drivers for the graphics card and hope everything works out, or downgrade Directx9 back to 8.1 (upgrading my graphics aswell maybe). The only problem is I've tried to go back to Directx 8.1 but it wouldn't let me.

So, anyone got any advice for me?

  Simon_P 19:28 09 Feb 03

Uninstall is not availible for DX9.

Is it a new card?

Ti4600 only suports DX8x but should work fine with DX9 dont think that it makes a difference performance wise just added graphic and sound enhancements.

have you got your mobo AGP drivers installed?

if not agp will work in PCI mode. is your AGP set to X4 in bois X8 if your mobo suports it?

Cant remember much about win 98 but think updating drivers may help a little, but think that there is an underlying problem. doubt it is caused by DX9

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…