cpu bios revision issues , sempron

  KevinBates 11:49 24 Apr 14

hi all. i hope someone can help me here. i have an ASUS M2V TVM motherboard that supports an am2 socket. I had a sempron 3000 cpu installed but for some reason it stopped working. I figured i needed a new cpu and decided to get the athlon 64x2 2200mhz. the manual says it supports it so why not.

Anyway i installed that and it was coming up with processor unknown revision at the post screen. I figured i needed to update the bios but i couldn't get into windows to do that. I tried updating the bios via a flash drive, cd etc but none worked. The pc dont have a floppy so that's out of the question. I then decided to just buy another sempron, the same as the last one hoping i could atleast get online and flash the bios that way. iv installed that and im getting the same issue as the first sempron. The pc isn't coming on at all. the motherboard kicks up, the fans etc are spinning but there's nothing coming up on the screen. im stumped. the pc boots with the athlon cpu but still shows unknown revision and the os wont start iv tried 100s of instructions on booting a usb flash drive with asus update utility and the rom file. it says getting ready to update do not turn off etc then it says ERROR unable to open rom file. iv been trying to sort this for over a month now.

if i can get the semprons to work i can flash the bios for the athlon. Anyone know why its stopped working with sempron cpus? it worked fine with a sempron before? also does anyone know why im getting error unable to open rom file? Iv tried renaming it etc but nothings worked. This is a nightmare :(

This thread is now locked and can not be replied to.

AMD Ryzen release date, specifications and features: Three CPUs from the Ryzen 7 range now…

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

Best iPhone games 2017 | Best iPad games 2017: 162 fantastic iOS games that you need to play right…