Connection problem

  JohnC123 20:43 07 Aug 05
Locked

I hope one of you experts can help me
Ihave a D-Link wireless network connectng one pc with 3 laptops.
One of the laptops which was previously connecting properly is now telling me that although it is connected its connection status is "limited or no connectivity" it says "this problem occurred because the network did not assign a network address to the computer."
I tried some of the solutions previously shown in this forum such as downloading the patch for SP2 etc; but - I really don't think they apply as the computer is fairly new,(2 months); it came already loaded with XP- Home and SP2 and in fact - up until a few days ago has been connecting to the internet perfectly.
Any help will be appreciated. - John

  Taff36 21:29 07 Aug 05

Which D-Link Router is it? Wireless connections vary dependant on signal strength, (distance from the router, obstructions such as walls, floors, ceilings etc) and interference from other wireless activity. (Microwaves / Cordless phones for example.)

Have you tried the repair facility for that connection which is on the support tab and what is the signal strength reported when this happens?

  JohnC123 21:36 07 Aug 05

D-Link DSL - G604T - I tried the repair facility - no improvement, its not a problem of distance, the other laptopsconnect anywhere in the house, this one is next to the router.
Signal strength is reported as Excellent - speed 54 Mbps. The problem seems to be with the IP address. Do you think if I press the reset on the router and start again it might resolve it. Or maybe I should try a system restore on the main pc to a time when the whole network was working properly ?

  scotty 11:05 08 Aug 05

Goto START and select Run. In the dialogue box type ipconfig. This will bring up a command prompt window with details of the IP address assigned to the computer. Type ipconfig /release then ipconfig /renew. This will get the router to assign a new IP address to the computer.

  JohnC123 11:25 08 Aug 05

Scotty:
Thanks - how do I get the window to stay open ? Whenever I do "Run ipconfig" a black window flashes on my screen then promptly disappears !

  scotty 11:29 08 Aug 05

Sorry, wrong instructions for XP. Goto Start\Programs\Accessories\Command window (or similar wording!). This will open a command window where you can type the above instructions.

  JohnC123 11:38 08 Aug 05

Hello again Scotty - I did that - it removed the wrong IP address and then when I told it to renew - it brought the wrong one back again- exactly the same as before - the IP address should start with 192.168 - this one is coming up with 169.254......

  Taff36 11:43 08 Aug 05

My favourite router! OK try this first. Turn off all PC`s and then unplug the router for 5 minutes. Turn it back on and wait for the WAN and ADSL led`s to become constant green and the status light intermittently flashing. Now turn on each PC and check that it can access the internet. Do the problem PC first and post back as soon as one fails. I`m around for about an hour. I think the problem PC isn`t set up to "obtain IP addresses automatically" but check this procedure first.

  scotty 11:46 08 Aug 05

Is there any other hardware attached that could be issuing an IP address?

Could the problem be a firewall preventing communication with the router?

  JohnC123 12:04 08 Aug 05

Well I did as you suggested, still got the same problem. As far as I know there is no other hardware that could be making an IP Address, as far as firewall, I have Norton on the problem laptop and the same is on my daughter's laptop which works perfectly through the router - like this one did until a few days ago.
I even tried disabling all firewalls and antivirus programs but still the same - I wonder if I should just reset the router and start again ?

  Taff36 12:48 08 Aug 05

Ok - on the problem laptop go to Control Panel>Network Connections and right click the wireless connection then Properties. Select (Highlight) the TCP/IP Protocol and go properties again. Now make sure that both the radio buttons for "Select automatically" are selected.

Also do you have an ethernet (LAN)connection. If so right click it and disable it - you can re-enable it at any time should you need it instead of the wireless connection. If the other computers are workingfine it`s not likely to be the router.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…