Connection OK in b mode but not g mode

  Dipso 22:01 24 Feb 05
Locked

I set up a Netgear DG834G a couple of weeks ago to network my desktop and laptop. The wired connection was working well from the start but the wireless connection was a bit iffy.

I previously failed in an attempt at Ad Hoc wireless networking and began to wonder if it was likely to be a fault with the wireless card in my laptop.

I have since tested the laptop in a public WiFi Hotspot and it connected without problems.

I have narrowed down the problem to be when the router is in b and g mode. If I change to b mode, the connection is fine, however if I revert to b and g the connection goes down from 54Mbps until it gets to 1Mbps then I get a yellow exclamation mark and a "Limited or No Connection" message. Last night I got a message something about the laptop not having an assigned IP address and was given the option to repair. I attempted to repair but nothing happened.

I have checked the wireless card properties and it is set up for b and g.

I can do what I want to do using b mode but I would like to try and resolve this if possible.
Can anyone offer any advice?

  Charence 22:45 24 Feb 05

Does it work in g only mode?

Try manually assigning the TCP/IP settings.

IP Address: All unique (device connect to net directly should have 192.168.0.1)

Subnet Mask: All same (eg. 255.255.255.0)

Default Gateway: IP of device connecting to net directly (192.168.0.1)

DNS Server: IP of device connecting to net directly (192.168.0.1)

Try that. Also check for firmware updates from Netgear.

Charence

  FelixTCat 22:57 24 Feb 05

How far is the laptop from the router? 11b tends to have greater range than 11g, so it may be that range is the issue.

Set the router to b&g and set up the laptop beside it. If it works well, move the laptop away until it reaches its limit.

Solid walls, furniture etc can reduce the range considerably.

  Dipso 07:07 25 Feb 05

FelixTCat - This happens when the laptop is right at the side of the router.

Charence - I haven't tried g only mode. I have more time tonight so will try what you suggest. I have the latest non beta firmaware and am loathe to use beta until I exhaust all other possibilities.

See ya later ;)

  FelixTCat 11:35 25 Feb 05

If your laptop is Centrino-based, open the Intel PROset software and click on the Adapter tab and open the Power Settings Congigure window. Check the power setting.

  Dipso 13:12 25 Feb 05

It is a Centrino but it didn't have the Intel PROset software installed when I bought it. I have to use Windows to configure. I will see what power options I can find tonight, at work now.

This may be unrelated but when I first boot the laptop, it comes back with no network found, it takes a few minutes and then it finds it. As this is my first dabble into wireless, is this usual?

  FelixTCat 14:34 25 Feb 05

Yes, that's usual. How long it takes depends on a lot of factors, including external interference. A lot of other devices radiate in the same frequency bands, e.g. microwave ovens, TV senders (sending TV signals from one room to another etc.)

I put my laptop to standby from time to time. Sometimes it immediately reconnects, sometimes it takes a few seconds, for no obvious reason.

  Dipso 23:56 25 Feb 05

First of all I changed my router to g mode only. This gave similar results as before, connection dropping or limited connection message.

I only wanted to try manually assigning IP addresses as a last resort as I didn't really want to start fiddling about with IP addresses unless really necessary.

I had already downloaded the latest driver from the Intel site but was hesitant to install it due to a disclaimer that it may not be compatible with my hardware. I thought, oh what the heck! and I went for it.

I noticed an improvement immediately as the wireless light on my laptop came on as soon as I rebooted, this resulted in the laptop picking up the connection straightaway rather than me having to wait for a few minutes like before. I have been testing the wireless network connection since installing the new driver (about 45 minutes ago) and so far touch wood (oh no, just got a page cannot be displayed) it has been fine, connection varies in speed from 48 to 2 Mbps but it doesn't disconnect or give the limited connectivity message (spoke too soon, just disconnected!) believe me this is 99% improvement on how it was before.

Hopefully this has resolved my problem. Thanks for your help. I will be back if everything goes pear-shaped and hope you are still around!

  Dipso 00:04 27 Feb 05

When I booted up the laptop tonight, it reverted to the No Wireless Networks Found and the Limited or No Connectivity messages. I could tell it wasn't working as well as last night as the wireless light didn't come on immediately as it did last night.

I forgot to say that I did try altering the power settings but that didn't make any difference either.

I manually assigned the IP address as per Charence's post but although the connection didn't drop, the internet connection was very slow, even though the PC which is running on the same connection was fine.

I have got fed up now and reverted to b mode again as this is completely problem free.

  The BB 17:20 28 Feb 05

On your laptop, see if you can see other networks; it might be a neighbour causing problems so you could try changing the channel in case you are getting interference.

  Dipso 22:17 28 Feb 05

Thanks for looking in on my thread. I have Net Stumbler in addition to the Intel software and I there doesn't appear to be any other networks in range.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…