Configuring Client Computer - ICS

  Samlebam 17:32 26 Nov 07
Locked

Two laptops, both running Vista Home Premium.

Host laptop has two wireless cards; one connecting to the Internet and the other connecting to the ad-hoc network.
ICS has been enabled for the Internet connection. IP address and DHCP set to 'obtain automatically'.

Both the laptops can connect to the ad-hoc network and thus to one another with no trouble.

However, the client computer cannot connect to the Internet. It doesn't appear to be registering the fact that ICS is enabled on the host computer.

Am I just being really thick here or should it just work? Do I need to do something magical to configure the client computer to pick the Internet connection up?

I have tried setting up a new internet connection, and opting to have it connect via the ad-hoc network but the wizard keeps failing to find the Internet.

Two laptops, both running Vista Home Premium.
Host laptop has two wireless cards; one connecting to the Internet and the other connecting to the ad-hoc network.
ICS has been enabled for the Internet connection. IP address and DHCP set to 'obtain automatically'.

Both the laptops can connect to the ad-hoc network and thus to one another with no trouble.

However, the client computer cannot connect to the Internet. It doesn't appear to be registering the fact that ICS is enabled on the host computer.

Am I just being really thick here or should it just work? Do I need to do something magical to configure the client computer to pick the Internet connection up?

I have tried setting up a new internet connection, and opting to have it connect via the ad-hoc network but the wizard keeps failing to find the Internet.

IPconfig/all details for the host computer:

Microsoft Windows [Version 6.0.6000]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Users\Brocklehurst>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Brocklehurst-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

PPP adapter Alice Fake:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Alice Fake
Physical Address. . . . . . . . . :
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 85.178.16.217(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 0.0.0.0
DNS Servers . . . . . . . . . . . : 213.191.92.86
62.109.123.7
NetBIOS over Tcpip. . . . . . . . : Disabled

Wireless LAN adapter Wireless Network Connection 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : SITECOM WL-168 Wireless Network USB Adapt
er 54g
Physical Address. . . . . . . . . : 00-0C-F6-35-09-C1
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::c47a:672a:b185:a8e%13(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.10.142(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 352324854
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR5007EG Wireless Network Adapter

Physical Address. . . . . . . . . : 00-15-AF-3F-77-E6
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Temporary IPv6 Address. . . . . . : 2002:55b2:9f4:a:2c89:b2d9:d65f:70fc(Depre
cated)
IPv6 Address. . . . . . . . . . . : 2002:55b2:9f4:a:e811:da40:ff78:a131(Depre
cated)
Temporary IPv6 Address. . . . . . : 2002:55b3:23fb:a:5061:d577:d64e:a8a2(Depr
ecated)
IPv6 Address. . . . . . . . . . . : 2002:55b3:23fb:a:e811:da40:ff78:a131(Depr
ecated)
Link-local IPv6 Address . . . . . : fe80::e811:da40:ff78:a131%10(Preferred)
Site-local IPv6 Address . . . . . : fec0::a:e811:da40:ff78:a131%2(Deprecated)

IPv4 Address. . . . . . . . . . . : 192.168.0.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fe80::e811:da40:ff78:a131%10
NetBIOS over Tcpip. . . . . . . . : Enabled

CONTINUES IN ANOTHER THREAD

  mgmcc 08:48 27 Nov 07

<<<< However, the client computer cannot connect to the Internet. It doesn't appear to be registering the fact that ICS is enabled on the host computer. >>>>

ICS *ISN'T* enabled on the host computer. At the top of the IPCONFIG /ALL details note that it says:

IP Routing Enabled. . . . . . . . : No

which means ICS hasn't been enabled on the Internet connection. You also have TCP/IPv6 enabled and this should be disabled.

Other than that, you should go with the help in your other thread to connect all computers to the router. If you are connecting with PPPoE to the service provider, there is only *one* PPP connection to the service if you use a router, the "client" computers connected to the router don't use Point-to-Point Protocol (PPP) to connect.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

New Corel ParticleShop plugin now available: 11 new brushes & 6 new brush packs

Apple AirPods review: Apple's beautiful new Bluetooth headphones bring true intelligence to…