Compaq Laptop: Not booting: Black screen: No BIOS

  faithhealer 18 Dec 12
Locked

My 4 years old Compaq Presario c700 (C794) laptop is not booting up. Does not go into BIOS, and does not even show the message “Press F10 to enter BIOS” etc.

  • I see a clear black screen (but has backlit and I am able to adjust the brightness using Fn keys). Tried on the desktop monitor, it is black too.

  • The HD is running intermittently, all LEDs are on, and the fan is running.

  • Windows is not booting up, there is no log on sound. WIFI light is also orange, it becomes green after booting is complete. HD activity is on but it is not as much to boot up Windows 7.

Troubleshooting I did till now:

  • Hard reset by holding down the power button several times.
  • Cleaned RAM and placed it in another slot.
  • Removed the power and battery and kept it overnight.
  • Tried on the desktop monitor, it is black too.

This happened all of a sudden. I did not do any BIOS updates or anything that normally causes these kind of problem. I learned from some forums that an exhausted CMOS battery can cause it. Is it true? In this case, can you please give the location of the CMOS battery in these laptops?

What are the other measures I can take?

  onthelimit1 18 Dec 12

I doubt it's the CMOS, but if you want to try, there is a service manual here. More likely to be the graphics chip, I would have thought.

  faithhealer 18 Dec 12

Thanks for the manual.

I thought it could be the Video card, but there is no sign of Windows booting up. I tried another monitor, it was black too.

  onthelimit1 18 Dec 12

'Video card, but there is no sign of Windows booting up'

Exactly - because the screen stays black, and the same with a separate monitor, that's why I think the graphics chip is the most likely culprit.

  Fruit Bat /\0/\ 18 Dec 12

Make sure nothing in DVD drive

Disconnect all usb devices / cards

Remove HDD and see if it boots to an error message

  woodchip 18 Dec 12

as above try booting to bios with hard drive removed

  faithhealer 19 Dec 12

Thanks for your suggestions.

Last night, I removed the RAM and tried to boot. I could not hear any beeps as I was expecting. But the glow (backlit) of the screen was gone. I restored the RAM and the backlit was back.

I will remove the HD today and see.

  faithhealer 19 Dec 12

Thanks for your suggestions.

Last night, I removed the RAM and tried to boot. I could not hear any beeps as I was expecting. But the glow (backlit) of the screen was gone. I restored the RAM and the backlit was back.

I will remove the HD today and see.

  faithhealer 31 Dec 12

Laptop is working after CMOS reset. Thanks for all your suggestions.

  Fruit Bat /\0/\ 31 Dec 12

Thanks for the feed back

Glad you got it working again.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message