Comcast not working. Please help.

  KainWilliams 02:00 03 Feb 06
Locked

Installers came in yesterday and set up comcast for the three computers in my house: a laptop (XP), and two desktops (XP and ME). Everything was working great until I had to factory restore my ME desktop because of a faulty download. So after the restore, I reinstalled what I believe is a 54M WLAN USB Adapter (for a wireless network) along with it's drives. The Ralink Icon successfully reappeared on my toolbar and even managed to display that I was "connected" on the Site Survey tab. However, when I run internet explorer to get onto Comcast.net, it looks for proxy settings for a while and then goes to an "Unable to display page" screen. I've tried a few things here and there: checking registry keys, configuring internet connections, etc. but to no avail. Actually, I don't understand a lot of the terms with LAN, so any help may have to be accompanied with some sort of consideration of this. Please help.

This thread is now locked and can not be replied to.

Qualcomm Snapdragon 835 benchmarks: Antutu, Geekbench 4, GFXBench and PCMark results

1995-2015: How technology has changed the world in 20 years

This animated short film tells a moving story of domestic violence for Refuge

New iPad 2017 preview: Apple's affordable but underspecced new iPad may appeal to the education…