Codewarrior and Java

  racoonboy 16:28 06 Jan 03
Locked
  racoonboy 16:28 06 Jan 03

I have used codewarrio successfully with Winodws ME for some time. Now upgraded to XP, I get the following error message when trying to compile a java program:
"Could not initialise java VM. Make sure the JDK is installed properly".

A JDK is installed (Version 1.2.1, the same one I always used), and codewarrior runs on another computer with XP and the same copy of the JDK and codewarrior.

Anyone have any ideas? I can find nothing useful online about this.

Ta, RB

  spikeychris 18:27 06 Jan 03

You say you have searched so if you have seen the below apolgies....


JDK 1.4_01 should work with CodeWarrior Pro 7. Make sure that you have all updates installed.

For some reason, CodeWarrior isn't seeing your installation of the JDK. There's a file called JVMDB.xml , find it and delete it (with CodeWarrior closed). This file will be automatically regenerated every time you open CodeWarrior. This file contains all the information that CodeWarrior needs to find the JDK's that you have installed.

click here

Chris

  racoonboy 11:06 07 Jan 03

THanks Chris, but I'd already seen that one. I have Codewarrior Pro version 5. Im gonna try a backup and clean install to see if that helps.

RB

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Method Studios' title sequence for BBC series Taboo is truly unsettling

Best Pages for iOS tips | How to use Pages for iPad & iPhone: 6 simple tips to get more out of…