code 10 error with vista 64

  steeleez 21:09 19 Dec 08
Locked

Hi from a neewbie

I have just purchased a pc and installed vista 64, when I have tried to connect to the net via ethernet cable to my sky broadband router, it cannot find a network connection. When I have looked on device manager there is a yellow triangle with an exclamation mark on my network card, drilling into it I get the following error, 'The device cannot start (Code 10)'. The network card is a Realtek RTL8168/8111 Family PCI-E Gigabit Ethernet NIC(NDIS 6.0).

Any help would be greatly appreciated.

Gary

  rdave13 21:19 19 Dec 08

Sounds like a duff network card. As it's a new machine contact the seller with your problem. It should be under warranty.

  recap 21:20 19 Dec 08

Hi steeleez click here for a possible solution to your problem.

  MAJ 21:25 19 Dec 08

Make sure the network card is enabled. Go to Control Panel > Network connections (not sure what it is in Vista), right-click on the Network card and choose Enable. Probably not the cause as they are usually enabled by default, but worth checking.

  skidzy 21:25 19 Dec 08

You need to install the driver Gary

This should do the job click here

Or click here

  steeleez 10:28 20 Dec 08

Thanks for the replies, I have tried updating the drivers, 'windows has determined the driver software for your device is up to date', I've tried uninstalling and re-installing it. Still no joy, I have noticed that I have got the same code 10 problem with my standard VGA graphics adaptor as well.

Any other ideas, the support dept where I purchased the pc from is closed (75p per minute premium number too!)

Thanks

Gary

  steeleez 10:54 20 Dec 08

Hi

I was updating the drivers from the wrong path, I updated them from the latest download and its working fine, thanks for your help.

Gary

  khoobsort 12:11 14 Dec 09

Hi
I have having the same problem with my PC. I was using the same PC with Win XP then installed Vista Home Premium 64 bit and every thig was fine. Installed Win 7 on my other laptop then got problem with network connection on the laptop. Could not find a driver for Win 7 for this router then connected it through Ethernet cable and tried to use PC internet connection through USB connection but could not install USB driver for this router. While trying other things including using a wireless router the PC started to give the following message:
There are driver or hardware problems with the network adapter "Realtek RL8168/8111 Family PCI-E Gigabit Ethernet NIC (NDIS 6.0)"
Drive manger is displaying this status message:
The device cannot start. (Code 10)
Windows is displaying that the derive is up-to-date .
Please help me get out of the problem.
Thanks
Khoobsort

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…