CMOS not remembering its settings

  jessej 16:50 03 Oct 04

Further to my last post about a rebuilt computer.
Everything is up and running, the hard drive was the problem there and a new one cured that. Even the old recovery CD formatted it then loaded 98SE (surprise, surprise, I was under the impression that a recovery disc would only work on the original HD)
The problem now is with CMOS, it will not remember settings in between boots. The computer starts up fine then tells me the settings are wrong, press F2 to load defaults. The time has reverted to 1st January 1998. So into BIOS and set everything up yet again, press F10 to save and exit. Next time I boot up it is back to square one.
The battery was a new one, I have had it out and checked it with a meter and it is as fully charged as you would wxpect a new one to be. I checked the contacts and they appear fine. I have also checked the CMOS jumper, that is where it should be. I've tried moving it to clear all settings then back to normal again, set it all up and rebooted, staright back to square one again. I do hope somebody will prove me wrong but this is beginning to look serious, along the lines of a new motherboard.

  OwenLotts 16:55 03 Oct 04

Try another battery. Seen a "new" battery do this before. Another battery was all it took.

  Cuddles 18:03 03 Oct 04

The battery will probably be a CR2032.

  Diemmess 18:18 03 Oct 04

I would do as OwenLotts suggests. Mercury batteries will sustain a very accurate voltage particularly when very low current is taken from them.

Under load however small, a faulty construction may drop the voltage to zero. If you used a digital meter to check, then it may be that it "looked alright" but since virtually no current was taken, it didn't show a fault. ..... They are cheap enough to be able to say "Oh shucks" and bin the duff one.

It is significant that the date goes wrong on shutdown. Unless you are changing other settings in the BIOS from default you can still use your computer, but don't trust the date which will be wrong on all files that you play with meanwhile.

  Dorsai 18:21 03 Oct 04

If a flat battery, and they are cr2032, dont pay more than £1.70 each. Any vauxhall dealer sells them, they fit about 90% of vauxhall car alarm remotes.

But i am sure they can be found cheaper elsewhere.

Otherise, have you accidently dislodged the clear cmos jumper?

  Caså 20:52 03 Oct 04

I have a spare PC that is the same.A new battery only lasts 2 or 3 days,I assume it is a mobo fault.I just make sure I do not switch off at the wall.

  Giggle n' Bits 21:36 03 Oct 04

or is the housing to the Battery got any damage ?
Clear your CMOS after replacing the battery reset CMOS now try it.

When clearing the CMOS be sure to disconnect the Power lead from you PSU on computer.

  jessej 09:05 04 Oct 04

Many thanks, as always, to all who responded. It was certainly very interesting to learn that a new battery could be obtained from a Vauxhall dealer for £1.70, mine cost £2.99 from Boots. Blue Note wins the prize though, I checked the battery, again, then rechecked the contacts. But what I had not done before, other than checking the CMOS jumper was in the correct position, was take out the jumper and swop it round to clear settings on pins 2 and 3 then after a few seconds, as the book says, return it to the normal setting on pins 1 and 2. This appears to have done the trick. So once more, many thanks to all.

  Diemmess 17:21 04 Oct 04

Well done and thanks both for the tick and most of all the explanation. That way we all benefit.

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…