Cipher.exe (unrecognised command)

  Chegs ® 03:56 05 Jun 04

I have XP Home,I have been reading up on deletion(or more precisely,secure deletion)of files.I found this page click here;en-us;q315672&sd=tech but everytime I try it I get "unrecognised command" messages.Is it just my XP Home that doesn't carry it or does anyone else have a similar problem?

I'm not particularly bothered that it doesn't work as nothing on my puter requires secure deletion,but if M$ say its there,why doesn't my puter recognise the command?

  Chegs ® 03:58 05 Jun 04

click here

The link in my previous post has suffered the dreaded PCA format cockup,so use this one instead.

  MartinT-B 10:25 05 Jun 04


at the bottom of that screen it says:

The information in this article applies to:
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Professional

Now, I don't know whether XP is a development of 2000 or not, so can't tell you whether the resolve for win2K should work for XP home.

  Chegs ® 10:39 05 Jun 04

It also says..."Administrators can use Cipher.exe to encrypt and decrypt data on drives that use the NTFS file system and to view the encryption status of files and folders from a command prompt. An updated version of the Cipher tool has been released for Windows 2000, and is included with Windows XP. "

  anon1 11:00 05 Jun 04

You have to pay careful attention to the commands in particular the spaces involved eg
cipher /w:driveletter:\foldername
note the space after "cipher" I have just tried it on my computer and works fine. You must also make sure you run from the command prompt and not the run box. when you hit run then type cmd then hit enter the resulting window will need to be on the c prompt if it is anything else it will not work. in the event of it being any other prompt eg c:\folder then you need to type cd c:\ (note the space after cd) hope that helps. Of course be careful about what you are deleting.

  Chegs ® 11:36 05 Jun 04

I have tried it several times over,with various folders/partitions,and keep getting the unrecognised command.I also tried it on my daughters PC(XP Pro)and got the same report.I did pay attention to the spaces etc,but cipher isn't recognised by either OS.I also used cipher/cipher.exe on the off chance my OS was acting thick. ;-)

  Chegs ® 12:47 05 Jun 04

Microsoft Windows XP [Version 5.1.2600]

'cipher' is not recognized as an internal or external command,
operable program or batch file.

The exact error message wording.

  anon1 14:25 05 Jun 04

I have exactly the same os and service pack 1 installed although I have xp pro and it works fine for me. Have a look in c:\windows\system32 (assuming c is the root drive) and see if it is installed. DO NOT try and install it if it is not as your hard drive could be wiped, there is a specific way of installing it.

  anon1 14:28 05 Jun 04

another thought after my last posting. You are logged on as an administrator I take it. Although that should not produce the error you printed.

  Chegs ® 14:38 05 Jun 04

No sign of "cipher" on my hdd's,other than the shortcut to IE fav's.I will dig out my XP CD and have a look thru it for "cipher".

  Chegs ® 14:39 05 Jun 04

PS: I only have one account (mine) on my machine.

This thread is now locked and can not be replied to.

How to watch Windows Event live stream, live blog | Microsoft event live stream: Watch Microsoft…

1995-2015: How technology has changed the world in 20 years

This amazing app turns your iPad Pro into a Cintiq

iPhone 7 Plus review: A superb big-screen phablet, but the price tag's enormous | iPhone 7 Plus…