Change to MTU in Windows XP does not appear to wor

  mpanosh 13:36 27 May 07
Locked

Hi,

I have recently purchased a Vodafone USB 3G modem to access the Internet from my ASUS laptop, and it's been horribly flaky. It disconnects for no obvious reason - even though the Voda control panel thinks it is still connected - on a regular basis and my MS VPN which has been rock solid over many private and public networks drops out equally regularly even when the link is actually up.

Voda's help desk suggested that I reduce the MTU on the link to "1300 or even 1100" so I edited the registry and set a new DWORD as MTU=1300 (it's the last setting in the following Registry dump of the registry settings for the Voda interface and is 1300 in Hex):

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Tcpip\Parameters\Interfaces\{BD017D36-C2B2-4EF6-8F11-F32753849508}]
"UseZeroBroadcast"=dword:00000000
"EnableDHCP"=dword:00000000
"IPAddress"=hex(7):30,00,2e,00,30,00,2e,00,30,00,2 e,00,30,00,00,00,00,00
"SubnetMask"=hex(7):30,00,2e,00,30,00,2e,00,30,00, 2e,00,30,00,00,00,00,00
"DefaultGateway"=hex(7):00,00
"EnableDeadGWDetect"=dword:00000001
"DontAddDefaultGateway"=dword:00000000
"NTEContextList"=hex(7):30,00,78,00,30,00,30,00,30 ,00,30,00,30,00,30,00,30,00,34,00,00,00,00,00
"DhcpClassIdBin"=hex:
"DhcpIPAddress"="10.94.0.214"
"DhcpSubnetMask"="255.255.255.255"
"Domain"=""
"NameServer"="10.203.65.68 10.203.65.68"
"RegistrationEnabled"=dword:00000000
"RegisterAdapterName"=dword:00000000
"MTU"=dword:00000514

This has made a difference, but when I the tested the MTU size using an unfragemented ping such as:

ping 24.234.0.7 -l 1350 -f

I worked out that the MTU size is actually set to 1471 (or perhaps it's still 1500 if I add the TCP/IP overhead in).

So for some reason my MTU registry edit has not worked...or perhaps worked differently to what I was expecting??

Obviously, any thoughts would be appreciated because at the moment I my very expensive 3G modem is in danger of going in the bin.

Thanks, Michael

  Dipso 15:06 27 May 07

What does SG TCP/IP Analyzer
give your MTU as? click here

  mpanosh 16:26 27 May 07

SG TCP/IP Analyser gives the MTU as 1420 (full results are below) which suggests my ping test did not work well at all. Interestingly, MTU Discovery in enabled, so Voda should not have a problem with MTU size if they configure their end properly, but I guess they are only a communications company :-)

Cheers, Michael

TCP options string: 0204056401010402
MSS: 1380
MTU: 1420
TCP Window: 16560 (multiple of MSS)
RWIN Scaling: 0
Unscaled RWIN : 16560
Reccomended RWINs: 63480, 126960, 253920, 507840
BDP limit (200ms): 662kbps (83KBytes/s)
BDP limit (500ms): 265kbps (33KBytes/s)
MTU Discovery: ON
TTL: 100
Timestamps: OFF
SACKs: ON
IP ToS: 00000000 (0)

  Stuartli 18:10 27 May 07

Try DrTCP to make changes to the MTU and to find out the best settings:

click here

There are also articles on tweaking your BB connection:

click here

  Stuartli 18:12 27 May 07

DrTCP does the Registry tweaks for you and can be run from a Desktop icon as and when required.

  rdave13 20:52 27 May 07

Bookmarked.

  Dipso 22:19 27 May 07

BTW the ping test you mentioned earlier is how to work out your optimum MTU not how to find out what it's already set at click here

From what you say it does appear that your optimum is 1500.

  mpanosh 21:24 17 Jun 07

So much for Voda's help desk...the MTU on this problem was a furphy. It's actually the inactivity timer that is causing the problems. I edited the Vodafone INF and changed InactivityScale (as per a Microsoft MSDN article) so it has a longer timeout and the problem is solved.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…