CDROM NOT RECOGNISED?

  Gharte' 13:24 24 Jul 03
Locked

A Win98se pc fails to recognise/see a cdrom. It gets detected in POST at startup as primary slave or secondary master when connected as such, but it is not registered/listed in Win98se. There is its icon on the desktop, but when clicked the pc says ' Drive not available'. In BIOS all the drive settings are 'AUTO'. In 'My Computer' the cdrom icon is absent. In Device Manager however, even though the cdrom is not listed, there are exclamation marks on 'Primary IDE controller (single fifo)' and 'Secondary IDE controller(single fifo) listings. How do I handle this? Thanks in anticipation.

  MjM Hellfire 13:35 24 Jul 03

Is the cdrom on it's own? Sounds like your jumper settings are incorrect on the back of the cdrom. It maybe needs to be set to Master using the jumper.

Also, ensure the cdrom ide cable is fitted correctly.

  polar_king 20:09 24 Jul 03

also sounds like the mb drivers are missing, ie. north & south bridge controllers eg, 4 in 1 for via. how did the cdrom icon get on the desktop, only way for that to happen is create shortcut from within my computer. delete it and put fresh one up

  Gharte' 09:09 28 Jul 03

Thanks MjM Hellfire. Yes the jumper settings are correct. I have configured it for primary slave using appropriate jumper at the back and plugged into it the second ribbon cable connector with no success. I changed into secondary master by changing the jumper at the back appropriatetly and plugging into it the first connectoer on the ribbon in the secondary IDE onboard: still no success.

Thanks to you too, polar_king. Unfortunately you are not clear enough. I would appreciate it if you could be more elaborate and more explicit.
I look forward to hearing from you.

Thanks to you both.

  Stuartli 09:26 28 Jul 03

If it is the only drive it should be set for Master; a rewriter and CD/DVD-ROM drive should be Master and Slave respectively.

You should also check the exclamation remarks for the controllers to find out the problem.

  DieSse 09:26 28 Jul 03

Firstly, in Device mangler, delete the IDE devices with the exclamation marks . they aren't working correctly.

When you reboot, Windows will recognise them again, and may set them up correctly.

You can also try starting in Safe Mode - and then you may see lots of extra entries in Device Manager - delete all the IDE ones, and try another restart.

If they still have a warning after this, come back again.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

The Pantone Colour of the Year 2017 is Green

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…