CD/DVD 's not autoplaying

  bruno 09:46 06 Feb 11
Locked

I have a 14 month old HP desktop running Windows 7 and the CD player has suddenly stopped working on auto-play. It was OK all the time I had it and gave me a choice of what I wanted to do with the disc. Now,nothing happens. If I open Media player or Computer I can do what I want, so it does know that the disc is in there, and it performs normally whatever I ask it to do. I have double checked the default settings and can't get it to work. Any help appreciated.

  cowgirl66 10:14 06 Feb 11

If you go to Start, you will see on the right hand side of the Start Menu, "Default Programs".

Click on Default Programs, then click on "Change Auto-Play Settings.

In there you will see at the top of the list, Audio CD. In here you can choose to play Audio CD using Windows Media Player.

Click on Save at the bottom and that should work.

  cowgirl66 10:20 06 Feb 11

Try this for size.

click here

  bruno 10:21 06 Feb 11

I have already done this by a different method, but I did it again following your instructions and it just gives me a blank screen. I tried all the different settings but none of them changed anything. Thanks for the reply.

  bruno 10:32 06 Feb 11

I tried that download but it does not work on 64bit windows. Thanks for suggestion.

  Fruit Bat /\0/\ 10:41 06 Feb 11

click here

for Vista but windows 7 is exactly the same

  cowgirl66 11:03 06 Feb 11

Here's another suggestion. Somehow the autoplay settings in the registry may have been disabled, so it's worth having a look. Not seeing the Autoplay window when inserting a disc into the drive can be a symptom of this.

Run Regedit (registry editor) and navigate to the following key.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

Locate the AutoRun registry value in the right pane, and check that the value data for AutoRun is set as 1 (one), which is enabled. If it is 0 (zero), which mean disabled CD-ROM or DVD-ROM drive AutoRun process, re-enable the AutoRun by changing the value to 1.

I hope this helps.

  cowgirl66 11:08 06 Feb 11

And another line of detection to take is this if the above proves fruitless;

Ensure that Shell Hardware Detection service is running

Type “service.msc” in Start Search to run Services console. Locate Shell Hardware Detection, and ensure that the “Service Status” is Running, and “Startup Type” is Automatic. If not, start the service and change the Startup Type setting accordingly.

  cowgirl66 11:40 06 Feb 11

Sorry Fruit Bat, looks like I doubled up on you ;-)

  Fruit Bat /\0/\ 12:34 06 Feb 11

Better to be there twice than not at all, especially if it solves the problem :0)

  bruno 19:12 06 Feb 11

Well, between the two of you,you have provided the answer to my problem. So thank you very much.
The answer was in Fruit Bat's link. At the bottom was this suggestion-
NoDriveAutoRun registry key, which stored at the same registry location, meanwhile determine whether a particular connected drive should run AutoPlay function or not. When AutoRun is enabled on the drive, media is automatically started when it is inserted in the drive.

By default, Windows Vista does not add any NoDriveAutoRun registry subkey. And you probably don’t want to block any drive from AutoPlay too. So remove and delete all NoDriveAutoRun key in the registry.
I deleted the last line as it said and now it is all working properly.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…