CD/DVD optical drives

  pj123 16:05 10 Nov 05
Locked

CD/DVD problems.

Primary IDE has 40gb as master, 60gb as slave. Secondary IDE has DVD burner as master and DVD rom as slave. Also has a six-in-one card reader.

All working fine up until a couple of weeks ago. Now “My Computer” shows no CD/DVD drives but if a CD or a DVD is inserted in to either of the optical drives it shows up in “My Computer” as H:\ removable drive “compact flash” or I:\ removable drive “Secure Digital”.

These drives used to be F: and G: The BIOS detects them as Secondary Master and Secondary Slave.

Running Windows 98SE with 512mb ram.

  bremner 16:51 10 Nov 05

This is clearly a Windows problem as the BIOS is seeing the drives correctly.

What do you see in Device Manager and how is the Card reader connected?

  pj123 17:08 10 Nov 05

bremner Device manager for the CD drives show up as H: and I: I tried to change them back to F: and G: but it didn't work. The Card Reader is connected via USB. Device Manager and My Computer also show an F: and G: drive as removable drives. But when you click on either of them it gives an error message. "Not accessible"

  bremner 17:11 10 Nov 05

I would uninstall them all in Device Manager and reboot the machine and let 98 pick them all back up again.

  pj123 17:29 10 Nov 05

bremner, I thought it was a Windows problem as well so I tried sfc and got loads of .ocx files as corrupted or missing. When I tried the "Restore from" Win 98SE disc they weren't found, so I assumed they were not Windows problems. So where do .ocx files get restored from?

"I would uninstall them all in Device Manager and reboot the machine and let 98 pick them all back up again."
Good idea. will give that a go as well.

  bremner 17:42 10 Nov 05

I always thought the ocx files were on the Windows disk and this also suggests that they should be click here

This site has many ocx files for download click here

  pj123 17:50 10 Nov 05

bremner, thanks again. Giving both links a try.

  pj123 14:32 03 Jan 06

Another unresolved one. This wasn't my computer but a clients.

He hasn't been in contact with me since this thread was posted. Whether he thinks I'm incompetent or not I don't know.

So I will tick it as resolved anyway and hope he doesn't come back.

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the 2017 Oscar-winning VFX of The Jungle Book were created

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…