CD won't eject

  Vincent 11:06 02 Dec 05
Locked

Having had no difficulty changing CDs I have put a data CD in with my pictures on it into the CD drive, and now can't remove this CD. I have tried the tiny hole at the front with no success. Has anyone any suggestions?

  scotbruce 11:11 02 Dec 05

Window Explorer, right-click drive, Eject.

Shut down and try to eject as you do so - if not, use longer needle in hole at front of drive and push harder.

  vinnyT 12:34 02 Dec 05

If this becomes a reg occurance, it may be a good idea to place a shortcut to the drive on the desktop, so you can just right click this and select eject.

  Vincent 13:13 02 Dec 05

Thanks to all three respondents - I worked on the turning off one, and then on starting up and it finally came alive again. Thanks also for pointing out the right click on the drive sign, eject, which I had not known about.

  vinnyT 13:07 03 Dec 05

Welcome, glad you got it sorted.

  woodchip 13:12 03 Dec 05

its having problems reading the disc and will not let you have it back, if the light is on all the time

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…