CD Autorun Reg Entry

  prima12 16:06 19 Nov 05
Locked

Would somebody tell me what the registry entry should be for 'CDR AutoRun' & 'NoDrive TypeAuto' should be. My CD drive has decided not to autorun for some reason. Running W98se. P

  Peter 16:24 19 Nov 05

.

The text below might be of help to you.

A: Drive accessed when opening My Computer, etc?
Lifted from PC Answers Issue 106 (May 2002), Pg.81.
Alter the following registry key as shown below.
Key HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Value name
NoDriveTypeAutoRun
Value
95 00 00 00 (Was 99 00 00 00 or 91 00 00 00 as set by X-Setup for Auto Start on removable media, Zip drives, etc.)
A problem with the above solution is that it also stops other removable media e.g. Castlewood Orb drive, from auto running. A more drive specific solution is to add the NoDriveAutoRun DWORD under the same key. When the DWORD is added the default value is 0x00000000 (0). Each drive is given a value starting with A through to Z. A = 1, B=2, C=3, D=4, etc. To stop the autorun for the A Drive set the DWORD value to 0x00000001 (1).
The value for each drive is 0 for “on” and 1 for “off” using a binary value with the least significant digit for drive A, the next significant digit for drive B, the next significant digit for drive C, etc.
e.g. 101 to disable autorun for drives A & C, 110 to disable autorun for drives B & C, 1001 to disable autorun for drives A & D. This value needs to be translated from binary to hexadecimal before it is used as the DWORD value. Thus 101 becomes 5 and is used as the DWORD value of 0x00000005 (5) to disable autorun on drives A & C.

Peter.

  prima12 16:33 19 Nov 05

Hmmm?
My current Registry settings are:-
CDR AutoRun 00 00 00 00
NoDrive TypeAuto ff 00 00 00
Do I need to alter these? P.

  Peter 11:37 20 Nov 05

.

I don't know if it is safe/necessary to alter your setting. You could wait and see if anyone else comes up with further suggestions or you could back up your registry, and any important files, and try some changes for yourself and see what happens.

Be careful and if possible take a complete backup of your system. Messing with the registry can stop your system working completely.

Peter.

  BurrWalnut 13:36 20 Nov 05

If you mean Autoplay as opposed to Autorun you can find defective autoplay settings here click here

  Peter 21:11 20 Nov 05

I think BurrWalnut's link only supports Windows Server 2003; Windows XP and not Windows 98SE that Prima is running.

Peter.

  prima12 21:33 20 Nov 05

I had another PC before my present one so I managed to gain access to it as it's still in the family, and I had also had the same problem with that one at one time. I accessed the registry on it and found the entry was different to my current machine. My current machine 'NoDrive TypeAuto' was ff 00 00 00 , and the entry on my other PC was 5f 00 00 00. I changed my current registry entry to that and it appears to be as it was, but I've made a note of where and when just so I can change it back if necessary. Thanks to everyones input. P.

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…