Capslock Beep Missing

  jaycup 15:18 07 Feb 10
Locked

As a head-down typist I rely on the beep sound whenever the 'capslock' key is hit accidentally. Having installed Windows 7 quite recently I tried to set this 'alarm' up but I cannot hear any beep sound. I have checked and double checked the appropriate settings in the keyboard options of the Easy Access Centre and all the right boxes are ticked. The other sounds on my computer are ok , I can listen to music, tv, radio etc.. all through my speakers or headphones.
The 'beep' should come from the computer itself and I assume there is no problem there as the BIOS beeps are able to be heard. I would like to get this running again but I am at a loss as to what to try next.
I should add that I have just re-booted into Windows XP (dual boot) and this function is working properly so it looks like a Windows 7 problem. Could it be Registry based?.

  Graphicool1 17:46 07 Feb 10
  gengiscant 17:51 07 Feb 10

1.Press start button, choosing "All Programs", "Accessories", "Ease of Access", "Ease of Access Center".
2. When the "Ease of Access Center" window appears, scroll down and click on "Make it easier to focus on tasks".
3. On the following screen, scroll down to "Make it easier to type". Check "Turn on Toggle Keys".
4. Click "OK" to save your settings, then close the "Ease of Access Center" window.

This tip is for Windows 7

  I am Spartacus 17:53 07 Feb 10

On Windows 7 instead of the 'beep' coming from the motherboard speaker as it used to on XP it uses the PC sound system instead. Very annoying if you have the sound off.

  jaycup 18:49 07 Feb 10

Thanks for the responses, but as I said in my description of the problem I have already ticked and enabled the appropriate boxes in the Ease of Access Center and although I did not know that Windows 7 does not use the Motherboard speaker all my other sound options are working through the speakers so it cannot be that.

  jaycup 19:03 07 Feb 10

Thought you would like to know that I have cured the problem but I cannot sy exactly how but what i did do was play around with the option to "Turn on toggle Keys by holding down the Numbers Lock for five seconds" after enabling this option I held down the NL key and this gave other options and then the Nl key itself produced a sound (beeb) and then I was able to do this direct from the capslock key. I have now disabled the NL option and the capslock beep is still working but as 'Spartacus' already said this requires the speaker volume to be 'On'. All help is gratefully received and I thank you for that, without this I would not have solved the problem.

This thread is now locked and can not be replied to.

Qualcomm Snapdragon 835 benchmarks: Antutu, Geekbench 4, GFXBench and PCMark results

1995-2015: How technology has changed the world in 20 years

This animated short film tells a moving story of domestic violence for Refuge

New iPad 2017 preview: Apple's affordable but underspecced new iPad may appeal to the education…