Caps lock on all the time and selecting all programmes from, desktop

  Eileanbeag 23 May 13
Locked

My son has Dell Dimension computer running Windows Vista. He has recently had problems in that when he uses Word it appears that the Caps lock is on all the time. When he comes out of this and goes to his desktop if he tries to select another programme all the programmes on the desktop are highlighted. He runs Norton and it is not showing any problems. He has tried System restore and restore last known good configuration with no avail. Is this a virus and if so what caan be done.

This may be a stupid question, but I've got to ask it... He does know how to turn caps lock off, right? If he's tried this and it still doesn't work, your description of the symptoms makes me think that there's something wrong with the caps lock key that's making the keyboard think it's being pressed. (I say that because, if you click on an item and then click on another item with the shift key pressed, the PC will select all the items between the two items clicked on - which is what seems to be happening when he clicks on shortcuts on the desktop.)

By the way: for those of you who aren't touch typists, and who look at the keyboard all the time when you're typing - only to find out when you look at the screen that you've accidentally had the caps lock key on - I can't recommend 'Boldfinger' highly enough. It's hugely increased my productivity...

  lotvic 23 May 13

It sounds to me as if one of the shift keys is stuck down. This could be due to crumbs, muck etc in the keyboard. Pick keyboard up and turn it upside down and tap and shake (gently) to dislodge crud. This is best done when pc is switched off.

  Eileanbeag 23 May 13

No its not the keyboard as He has changed this top test it - which makes me think it is a virus

  Russ57 23 May 13

He may have accidentally pressed Ctrl/shift/A. This toggles between caps on and off. Try pressing them again to see if it clears it.

  lotvic 23 May 13

Ian in Northampton, wish you'd warned us about the loud music ;P

  rdave13 24 May 13

In Windows 8, control panel, language, advanced settings, change language bar hotkeys, in the pane that opens check that , under advanced key settings, the button is dotted for 'Press the CAPS LOCK key' for turning off Caps Lock and not the SHIFT key. Might be the problem. In Win 7, Control Panel, Regional and Language Options, Keyboards & Languages, Change Keyboard, Advanced Key Settings.

lotvic: sorry - I only rarely have my speakers turned on... :-(

  lotvic 24 May 13

Ian in Northampton, me too, and I'd forgotten they were on LOL

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message