Can't stay logged in to my favourite sites

  Pineman100 14:10 PM 28 Aug 12

I run Windows 7 Home Premium.

I've recently switched back to using Internet Explorer 9, after some years using Firefox (because new version of FF doesn't support Norton Identity Safe).

I have several websites that I visit regularly - Google Mail, PC Advisor, BT Yahoo and so on. As I have visited each of them in IE, I have logged in and ticked the "Remember Me" box. But none of them do - I still have to login again every time I visit them.

I suspect that IE may be refusing cookies, but I'm not sure how to overcome this problem. Please can you explain what to do?

Many thanks.

  Fruit Bat /\0/\ 14:25 PM 28 Aug 12

To block or allow cookies from specific websites

  1. Open Internet Explorer by clicking the Start button

  2. In the search box, type Internet Explorer, and then, in the list of results, click Internet Explorer. Click the Tools button Tools button, and then click Internet options.

  3. Click the Privacy tab, and then move the slider to a position between the top and bottom so you're not blocking or allowing all cookies.

  4. Click Sites.

  5. In the Address of website box, type a website address, and then click Block or Allow. As you type, a list of webpages that you've already visited will be displayed. You can click an item in the list and it will be displayed in the Address of website box.

  6. Repeat step 5 for each website you want to block or allow. When you're finished, click OK.

  7. Move the slider back to the position it was originally in, and then click OK.

  Pineman100 17:22 PM 28 Aug 12

Thanks very much for that advice,Fruit Bat /\0/.

I did exactly as you recommended, and now have all of my favourite websites now listed as "Allow", and the Privacy slider moved back to Medium. But I'm afraid this hasn't made any difference.

I restarted IE, I even restarted the computer, but it still requires me to login every time I visit one of the sites that I have listed as Allowed.

I've noticed one other odd thing. When I visit one of these websites, scrolling down the page is extremely sluggish until I've logged in - if I roll my mouse wheel it can sometimes take 15 - 20 seconds before the page responds. Once I have manually logged in, it behaves normally.

Do you think there's any chance that these two problems are linked?

  Fruit Bat /\0/\ 19:20 PM 28 Aug 12

I use Firefox as I find IE sooooo slow

just keep IE for the windows update site as the IE plugin for Firefox doesn't work well on my old XP system either.

  Woolwell 19:37 PM 28 Aug 12

Clear all cookies and the internet cache and then start again and see if that makes a difference. You will lose all remembered log ins though. Clear the cache first.

Or try Chrome or Opera but I don't know if they support Norton Identity Safe.

  Fruit Bat /\0/\ 11:12 AM 29 Aug 12

Also works if you click on Help - About - Check for updates

  Pineman100 11:35 AM 29 Aug 12

Thanks for those replies.

Woolwell - I'll try that, thanks.

Jock1e and FB - thanks for the suggestion - do you know whether FF 15 supports Norton Identity Safe?

  rdave13 11:42 AM 29 Aug 12

In IE, tools, internet options, general tab, under browsing history select the delete tab, make sure 'preserve favourite website data' is ticked.

  Pineman100 12:28 PM 29 Aug 12

rdave13 - thanks but that didn't help.

Jock1e - thanks for that. As you say, it seems that FF 15 will support the Norton Identity Safe system, so that would see to solve my problem.

I'll update FF and report back.

  Pineman100 15:18 PM 29 Aug 12

The problem is solved. I've updated to Firefox 15 and Norton Identity Safe is now running happily within it. So all is well.

Many thanks to everyone for their responses.


This thread is now locked and can not be replied to.

Microsoft Surface Pro 4 review: Hands-on with the new generation of Surface

1995-2015: How technology has changed the world in 20 years

Crowdfunding for world’s first 3D camera-computer found in 30 hours

2015 iMac release date rumours, specs, price & features: new 21in 4K Retina iMacs coming next week