Cant set to dma on slave hard drive

  jake williamson 11:06 29 Dec 03
Locked

I’ve two hd’s in my dell 8300, a 60gb that came with the machine and a IBM deskstar 82.3gb. I’ve put them both on the primary ide channel with the 60gb as device 0 and the 82.3gb as device 1.

I cant set device 1 to dma which is really impacting the disk and machine performance. Device 0 shows ‘device type auto detection, transfer mode dma if available’ and the ‘current transfer mode as ‘ultra dma mode 2’. Device 1 shows ‘device type auto detection, transfer mode dma if available’ and the ‘current transfer mode as ‘pio mode‘.

I’ve looked around in the bios and cant find anything - what should I be doing?

Any info would be great,

Cheers, Jake

  MichelleC 11:19 29 Dec 03

Have a look here, it may help click here DMA availablity is somewhere in bios, but as 1 hd is enabled I don't think it's a bios issue.

  jake williamson 11:58 29 Dec 03

hi, thanks for the reply. i had a good look through the link you posted and had a hunt on the dell forum.

in the end, it was in the bios. i checked out the settings under 'drive configuration'.

the primary master drive said hard drive. the primary slave drive said off. so i set this to auto and rebooted.

now the bios says hard drive and the current transfer modes on both hard drives is on 'ultra dma mode 5' - copying files is now soooper speedy!

thanks again,

jake

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

iPhone 9 and beyond: 32 amazing future smartphone developments - graphene, supercapacitor…