Can't log onto Belkin website

  Nic80 20:17 02 Sep 07
Locked

Hi I've been having some problems with my router so have tried to log onto the Belkin website. It wont load though, neither the uk or the .com one. All other sites are working fine it's just that one. This has been going on a few months now, it's only now when I have again tried to open their page after a few months I realised that I still can't get on.

Any ideas?

  VoG II 20:21 02 Sep 07

Try HostsToggle click here

  Nic80 20:34 02 Sep 07

Whats that?

  VoG II 20:37 02 Sep 07

It enables you to toggle your hosts file off or on. To do it the hard way go to C:\windows\system32\drivers\etc\hosts and rename it to hosts.txt then restart your PC>

  Nic80 20:40 02 Sep 07

I don't even know what host files are.

Can you explain please?

Can you also explain why said host would prevent my accessing the Belkin website?

  VoG II 20:43 02 Sep 07

click here

It is only a possibility but if Belkin has been added to your hosts file then worth a try, surely?

  Nic80 20:49 02 Sep 07

I don't trust your answer, you're telling me to install things without telling me what it is exactly.

Again, what is a host, and whats the hosts file?

  VoG II 20:50 02 Sep 07

Fair enough. Live with your problem. Goodbye.

This thread is now locked and can not be replied to.

AMD Ryzen release date, specifications and features: Three CPUs from the Ryzen 7 range now…

1995-2015: How technology has changed the world in 20 years

Glassworks Barcelona shows how it captured the artistic imagination of Conor in A Monster Calls

Best iPhone games 2017 | Best iPad games 2017: 162 fantastic iOS games that you need to play right…