Cant install new Christmas wireless key :(

  livewire 15:26 25 Dec 05
Locked

Ive just got my new Belkin Wireless USB key for Christmas. Ive inserted the CD and installed the drivers but when I plug the key in I get this error click here (screenshot). No matter how many times I uninstall, re-install or system restore I cannot install these drivers. :( Ive even tried different drivers from click here but they all give me the same error message :( click here

any ideas on how I can get this working or should I return the key to Amazon?

  VoG II 16:02 25 Dec 05

Can you post a link to the product that you are trying to install.

I had a spot of bother (understatement of the century) when trying to install a Belkin wireless card in my PC a couple of years ago.

  livewire 16:10 25 Dec 05

Sure, the wireless USB adapter is this one:

click here=

  woodchip 16:15 25 Dec 05

Did you put the Key in then put the CD in? If so you did it the wrong way round. Go to Device Manager and uninstall any yellow icon or ref to the key. restart comp without key, load CD drivers then plug the key in

  livewire 16:17 25 Dec 05

I did it in the right order CD and the the Key. But its still not installing :(

  Number 7 16:23 25 Dec 05

Have you removed a previous version of the software?

This refers to the part number you've posted click here

  livewire 16:37 25 Dec 05

Ive tried the suggestions on that page but still get the error. I even got this error the first time I installed the drivers from the actual CD that came with the device ?????

This thread is now locked and can not be replied to.

New Google phones UK release date | Pixel XL price, new features, specifications: Pixel X and…

1995-2015: How technology has changed the world in 20 years

This is the future of TV, VR and holograms

iPhone 7 review: Enhanced cameras, a refreshed design and water resistance make the iPhone 7 an…