Cant Install Net framework up-dates

  birdface 20:26 10 Jul 07
Locked

Hi.I can't install some of to-nights up-dates.KB928365. Kb928366. KB932471. All Net Framework I. 2 and 3. I usually update manually.So I don't know if thats the problem.I have tried rebooting a couple of times,But still cannot download the up-dates, Anyone got any ideas.It did update 2 other Microsoft programs,But not those three.

  VoG II 20:49 10 Jul 07

This is unclear. Can you download them but they don't install or do they not download at all?

  Jackcoms 20:55 10 Jul 07

I suspect that buteman has the same problem as me. They download OK, but then installation fails.

If we have net framework version 3, do we still need versions 1 and 2? Or can they be uninstalled?

  anskyber 21:11 10 Jul 07

I've just downloaded the updates on my XP laptop. It hangs on 1/3 install. I then got a ZoneAlarm warning which I accepted (it was OK) and the install continued, so it could be a security suite issue?

  birdface 21:25 10 Jul 07

Yes,Sorry they download ,but will not install.

  Snec 21:36 10 Jul 07

I've just this minute had a similar experience to anskyber. The 1/3 install hung for three to four minutes before taking off and completing.

It seems to be just a question of waiting?

  Jackcoms 21:38 10 Jul 07

I've solved the problem for version 1.

I uninstalled it via Add/Remove Programs and then went back to MS updates. Downloaded the whole lot again, including Hotfixes for that version, and everything installed OK this time.

However, Windows will not allow me to uninstall version 2, so I can't use the same solution as I did for version 1.

I still have the same problem - today's update for version 2 will not install.

  iscanut2 21:39 10 Jul 07

Have just had same problem woth .NET Framework 2 update. Downloads but fails to install, showing "Failed" and further investigation returns an error code of 0x643, which I can find no trace of in Microsoft help pages re update failures. I note that I also have version 1 .NET installed on the pc and the security upgrade for this version installed OK. Could this be a problem. Do I need both ? Should I remove version 1 and try again ? Any ideas ?

  birdface 21:39 10 Jul 07

Just get the message that downloads were not installed,But will try again.

  anskyber 21:41 10 Jul 07
  skidzy 21:41 10 Jul 07

Not 100% but i believe you can remove version 1.1 as this is incorparated in version 2.0.
Version 3.0 is unlikely to be needed unless you use some developing software or even the latest release of a programming software package.
Though i think (have not checked) version 3 comes with the MS updates.

Version 2.0 is needed,especially if you have some old software.

Sorry dont know the techinal details.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…