Can't get onto web site!

  curlylad 22:33 27 Oct 05
Locked

For some strange reason when I try to get onto the Crucial website click here I keep getting a page cannot be displayed , this has been happening for 2 days now so I am sure it is not a web site problem but something wrong my end , can anyone help me please ?

Thanks in advance (abbreviated to T.I.A in future)!

  VoG II 22:35 27 Oct 05
  curlylad 22:48 27 Oct 05

Thanks for that but still no dice !

  curlylad 22:49 27 Oct 05

Is anyone else having this problem ?

  dan11 22:58 27 Oct 05

Me to.I wanted to check the price of 2700. Must of tried half a dozen times in the last 24 hours. No go.

Even tried going through,.com and then change. But even .com wasn't showing.

I bought it through ebuyer in the end.

  alan227 22:59 27 Oct 05

Just tried and got straight in.

  spuds 23:31 27 Oct 05

curlylad--Same as you, also tried VoG's link, same results.Keep getting 'Connecting to 137.201.245.23' then 'The page cannot be displayed'.

  mco 23:56 27 Oct 05

I got it, no problem

  woodbasher 00:00 28 Oct 05

Just got on, no problem.

  curlylad 00:16 28 Oct 05

Just tried again still no good.It appears though that I am not the only one , so there may be some sort of problem with the site but then again if there was a problem with the site how is it that some people can get on and others can't , what a quandary.

Can one of you good people who can get on please get me an email address for their support or customer services , perhaps via their 'contact us' link ? I will email them and ask their advice.

  octal 06:37 28 Oct 05

This thread is now locked and can not be replied to.

New Google phones UK release date | Pixel XL price, new features, specifications: Pixel X and…

1995-2015: How technology has changed the world in 20 years

This is the future of TV, VR and holograms

iOS 10 troubleshooting tips: Simple fixes for the most common iOS 10 problems, from network…