Can't figure out the problem

  abf36 21:46 07 Jan 13
Locked

Something is seriously wrong with my PC. It doesn't POST anymore. This problem is somewhat intermittent.

When I press the power button I hear a click (relay) but nothing happens. There is a light on the motherboard (that is on).

The reason I say this is intermittent is because I stripped everything out and put it back together and it worked again for about a week. This has happened a couple of times now. But now it won't come back at all.

I'm pretty sure there isn't any loose connections etc. I've done pretty much everything I can think of including:

  1. power reset (holding for 30 secs)
  2. took out the RAM and powered up to hear beeps
  3. stripped and reassembled
  4. changed CMOS battery

I dont know anything else to try.

I suspect the motherboard is faulty but I cant be 100% sure which is why I need some help.

  Fruit Bat /\0/\ 21:56 07 Jan 13

first job would be to substitute the PSU and retry

  lotvic 22:46 07 Jan 13

Might be a faulty power button (sticking or not making contact) I've got an old pc that does that, button works fine for a while then suddenly at some switch ons, pc appears dead - (apart from light on motherboard which only shows mains power is getting through) nothing else happens.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? Why upgrade to Windows 10? Is Windows 10 good? The pros and cons of!…

1995-2015: How technology has changed the world in 20 years

This Uplifting Animation Celebrates Team GB’s Road to Rio

How to use Apple Music in the UK: Complete guide to Apple Music's features, including new features…