Can't download drivers for ethernet controller?

  paula727 04:02 29 Dec 14
Locked

Hi there, I am having problems connecting my ethernet from my router to my laptop.I have a packard bell easynote. I went to device manager and there is a yellow question mark beside ethernet controller. I went into my Hardware ids and this is what came up:

PCI\VEN14E4&DEV1692&SUBSYS036D1025&REV01 PCI\VEN14E4&DEV1692&SUBSYS_036D1025 PCI\VEN14E4&DEV1692&CC_020000 PCI\VEN14E4&DEV1692&CC_0200

I went to the second one and tried to find the driver for it but that didn't work. I have tried so many different things and nothing seems to work at all. I am not very computer savvy so maybe I am doing something wrong but it seems as though this driver has just completely disappeared from my laptop.

  onthelimit1 08:38 29 Dec 14

From the Packard Bell website here on a different computer, download the driver and save it to a flash drive. Then install it on your laptop.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

The updated 'Corel Painter inside Photoshop' plugin ParticleShop offers new brushes

New MacBook Pro 2017 release date, UK price and tech specs: Kaby Lake MacBook Pro to launch in…