Can't do D link network card installation

  Rockarch 20:00 19 Feb 05
Locked

Not usually being brave enough to take the back off a pc I thought I could manage to fit a network card! I'm trying to install a network adapter (DLink DFE528TX) into a win98se machine I have just inherited. Followed all the instructions & nothing happened so I took the card out again and put it into another PCI slot. Still nothing. In device manager under 'network adapters' it is not seen (just a dial-up adapter). I have run the add new hardware wizard & still nothing. I also have a suspicion that the driver files did not install properly from the CD (and have tried again) because it seemed too quick. Where should I look to find if the driver files are there.
I thought this would be a quick job but no. Any ideas please?

  LastChip 21:25 19 Feb 05

First, go to Windows explorer and investigate the driver disc that came with the card. You will probably find something like Drivers; Winxx or something similar. The point is, you need to know where the drivers are located on the CD.

Armed with this information, go to Control Panel; Add New Hardware and select; "No, I want to select the new hardware from a list". Click on "Network Adaptors" and "Have disc". Now follow the wizard, making sure you point to the drivers (use Browse) determined in the first step above.

  FelixTCat 22:19 19 Feb 05

It is worrying that when you fittd the card and restarted, windows didn't bring up the Found New Hardware window, or that the new adapter didn't show up in Device Manager with a big question mark in a yellow circle.

That mean that windows didn't notice that something new had been added.

Are there any unknown devices in Device Manager?

  Rockarch 22:21 19 Feb 05

Thanks last chip - I'll give it another go tomorrow & see what happens.

  Forum Editor 00:32 20 Feb 05

who had endless trouble when trying to do exactly the same thing as you. In the end she gave up. Someone else I know had a D-Link USB external wireless network adapter (a DWL 120 I think it was) and she never succeeded in getting it to work.

None of which is much comfort to you I know, but it sometimes helps to know that you're not alone.

LastChip's suggestion is a good one, I hope it works.

  Rockarch 11:46 20 Feb 05

Thanks for the suggestions - would you believe it - I booted the thing up this morning to try lastchip's suggestion and lo & behold up came the 'to complete the installation reboot' windows & it now appears to work. The only thing that happens which I didn't expect is that now on booting even though it is not connected to a network yet, I get asked for the network password. I need to try & remember how networking works in 98se as I've been using XP for so long I've forgotten anything I ever knew!
Thanks to all but it seems sorted now (famous last words)

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

Best Christmas Agency Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…