Cannot retrive LAC name

  keith8 21:29 PM 29 May 13
Locked

Hi,

When I start up my Acer Aspire 9410-2459 laptop, I keep getting a RTNICDiag error that says "APIGetConnNameW(): Cannot retrive LAC name."

Is there anyway I can get rid of or fix this problem?

keith8

OS Version: Microsoft® Windows Vista™ Home Premium, Service Pack 2, 32 bit Processor: Genuine Intel(R) CPU T2080 @ 1.73GHz, x86 Family 6 Model 14 Stepping 12 Processor Count: 2 RAM: 2037 Mb Graphics Card: Mobile Intel(R) 945 Express Chipset Family, 256 Mb Hard Drives: C: Total - 74614 MB, Free - 9667 MB; D: Total - 31855 MB, Free - 4749 MB; Motherboard: Acer, Myall2 Antivirus: Microsoft Security Essentials, Updated and Enabled

  Secret-Squirrel 09:11 AM 30 May 13

"When I start up my.......laptop, I keep getting a RTNICDiag error"

A Google search tells me that RTNICDiag.exe is the Realtek NIC Diagnostic Utility. It's doesn't appear to be an essential startup program or service so you may as well try to disable it from starting every time you boot your laptop. Vista's "MSconfig" is one utility that can do this. If you're not familiar with it then here are some instructions for you:

1) Click the "Start" button, type msconfig, the program should appear at the top of the list, so click on it.

2) Click the "Startup" tab. If you can see RTNICDiag.exe and/or Realtek NIC Diagnostic Utility in the list, untick it.

3) If it doesn't appear in the Startup list, click the "Services" tab, tick the "Hide all Microsoft Services" option and untick it if found.

4) Restart your laptop and see if that error no longer appears.

  keith8 22:06 PM 30 May 13

Hi Secret-Squirrel,

I did as you suggested But there was no RTNICDiag.exe or Realtek NIC Diagnostic Utility in the Startup list or the Services list. In the Startup list there was Realtek HD Audio Manager and RealPlayer (32-bit). I disabled each of them separately and restarted the computer after each but the error was still there. There was nothing Realtek or Real in the Services list.

In the Tools list under System Information, System Summary, Network, Adapter there is a Realtek PCIe GBE Family Controller shown.

In the Tools list under System Information, System Summary, Software Environment, Running Tasks there is a rtnicdiag.exe but there are no boxes to tick on any of the files in this list.

Thank you for your help.

Keith8

  Secret-Squirrel 10:19 AM 31 May 13

"there was no RTNICDiag.exe or Realtek NIC Diagnostic Utility in the Startup list or the Services list"

That's a shame - I was hoping you'd find it easily.

Another place to look would be Vista's "Startup" folder. You can get to it via the Start button -> All Programs. If you find something in there that looks like the Realtek network utility then you can right-click on it and select "Delete".

Advertisement

This thread is now locked and can not be replied to.

How to watch iPhone 6s, iPhone 6s Plus launch live: What to expect from Apple's 9 September 2015…

1995-2015: How technology has changed the world in 20 years

This installation lets you control a laser and sound show using your mind

Apple's special event invitations decoded: A look back at 13 of Apple's most cryptic invites