Cannot install printer or Spybot S&D

  plsndrs3 11:12 11 Nov 03

Hi everyone,

I have almost completed the installation of my larger hard drive [my thanks to all the Helpline Angels for help so far] and have just 2 final problems.

I have tried to install my HP All In One 750. The software loads & confirms installation OK. I then attach the USB lead and the PC 'finds' the scanner/printer but then I get the message 'an error occurred during the installation of this device. The RPC server is unavailable' The printer works OK on my laptop [OS win 2k] and worked on the previous drive with the same OS as the new one [WinXP].

My other problem is that I cannot re-install Spybot S&D. The program again seems to load OK but, when I click the icon the program flashes on screen for about 1/10th of a second & is then gone. I have deleted & re-installed this several times, changed the program to run under Win95 [but it has always been ok before] without success. I have Adaware, but like the idea of 2 seperate programs as one tends to sweep what the other misses. I also use Kerio Firewall and AVG, but do not recall any compatibility issues before - but I do not know if Spybot needs to be loaded before AVG or whatever?

Neither is really a MAJOR issue, it's just that I would like it to be set up as I prefer.

Many thanks,


  bigray 11:39 11 Nov 03

why not turn off Kerio & AVG, then see what happens,

  plankton 11:56 11 Nov 03

I believe you should have installed the scanner software before the anti-virus, so disable the AVG and then re-install the scanner s/w.

  BigMoFoT 12:01 11 Nov 03

The RPC service is the service that the Blaster virus targets and thus terminates. First of all check in your startup, start, type run and then type msconfig and check in the startup - look for MSBLAST.exe, if that is there then you have a variation of the blaster virus

  plsndrs3 12:30 11 Nov 03

bigray/plankton - will try this later today

BigMoFoT - No MSBLAST.exe, but no RPC either [?]

  plsndrs3 12:36 11 Nov 03

In the services tab of msconfig, spool services showing a status of 'stopped'. How do I change this to 'running'?

  wizkidwall_03 12:39 11 Nov 03

rpc is remote procedure call if you have xp go to control panel administrative tools select services and scroll down find rpc and restart the service or enable it
if it is disable enable it

  BigMoFoT 12:48 11 Nov 03

With the different strains of the virus it is possible you may not have msblast but something like "teekids" or "penis32" instead. All variations in someway affect that sam RPC vulnerability (I think you may have Welchia virus which is preventin you from installing any AV).

The RPC service should be running but the RPC locater service can be in a stopped state when not needed!!

  plsndrs3 12:55 11 Nov 03

Have changed the RPC to automatic & rebooted - still getting the same fault. Will now delete the software, close virus checker & firewall & try to install again.

  plsndrs3 13:26 11 Nov 03

The only ones I can see are avgcc32 [virus protector], hpgswnd [Hewlett Packard - the printer?] and ctfmon

  plsndrs3 13:31 11 Nov 03

Have disabled firewall & virus, deleted & reinstalled software - still have 'RPC rever unavailable' warning when plugging in printer - but software confirmed successful instal .....

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the 2017 Oscar-winning VFX of The Jungle Book were created

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…